LowRider2 with SKR V1.3

Ok, have all the parts printed and assembled to the flat boards.

Next is to build the table, but first want to get the SKR V1.3 and TFT 3.5 V3.0 boards set up and working.

Whats a good starting point for the firmware?


Pick the one with your driver’s and let in the name
For the screen

Assembler messages:
Fatal error: can’t create .pio/build/LPC1768/src/src/gcode/control/M280.cpp.o: No such file or directory
*** [.pio/build/LPC1768/src/src/gcode/control/M280.cpp.o] Error 1
Assembler messages:
Fatal error: can’t create .pio/build/LPC1768/src/src/gcode/control/M226.cpp.o: No such file or directory
*** [.pio/build/LPC1768/src/src/gcode/control/M226.cpp.o] Error 1
Assembler messages:
Fatal error: can’t create .pio/build/LPC1768/src/src/gcode/control/M350_M351.cpp.o: No such file or directory
*** [.pio/build/LPC1768/src/src/gcode/control/M350_M351.cpp.o] Error 1
Assembler messages:
Fatal error: can’t create .pio/build/LPC1768/src/src/gcode/control/M380_M381.cpp.o: No such file or directory
*** [.pio/build/LPC1768/src/src/gcode/control/M380_M381.cpp.o] Error 1

first compile error… these .cpp files are in the marlin/src/gcode/control folder

that was with Mariln AutoBuild… using the check mark build at bottom worked fine… no errors

auto build also now works… made no changes from the first try… go figure

Ok… progress…

loaded firmware to skr board and came up fine.
also loaded firmware and font directory to the display board. got some icon errors during the load.

can switch display from “marlin mode” to “touch mode” by holding the knob down.

v1 logo comes shows up and am able to control a stepper plugged into the x driver. but only from the “marlin mode” of the display. the “touch mode” of the display says “no printer attached”.

after power recycle… getting “illegal flash app”

You probably need to change the baud rate, which us in the menu setting in the tft.

The marlin builder zip comes with a preconfigured firmware, so you could have just put that on the sd instead without building it again in platformio. But glad it is working.

Thanks Jeff, you guys are a great help.

I needed to change the drivers from tcm2209 to tcm2208, that’s why the build in platformio.

Used the file BIGTREE_TFT35_V3.0.26.x.bin from the “Copy to SD Card root directory to update - Unified Menu Material theme” directory.

Was able to change the baud rate to 250000 and it works fine.

Thanks again!

2 Likes

I need help.I have always the same problem. I don’t know why.

I had that same issue last night Don. I had to update some of my files as it worked great 2 days ago and I played with setting up my firmware.