Mac, and Fusion360, Guffy's PP?

Hello, just wondering if anyone here have a working post processor I am using Marlin?

The one linked at the end of the Milling basics page has been proven to work for a while now, just make sure Arcs are turned off (for this version of Marlin).

What problems are you having with it?

I tried already more than 3 projects and get the same error always.

First I got this error:

[attachment file=120369]

but mostly is this one only:

[attachment file=120368]

Sorry Ryan, just post this reply but it is duplicated, I could not delete it, I am in Bangkok right now and the internet in the hotel is not the best :frowning:


I am not sure it works the same on a MAC. Can anyone confirm?

Does you post processor screen look like the github page?

I am not sure it is properly loaded.

Yes I downloaded from his GitHub page.

Does your post processor screen look like the one on the github page. I do not have or ever use a MAC, I am not sure if it works or not so that is my first assumption, if the screen looks the same I think it works. If not you might not have it loaded or it does not work on a MAC.

Yes sure is the same, how can we point Guffy to this post so maybe he can help?

I haven’t seen guffy around in a while.

Have you tried any other PP’s? I am not convinced it is loaded given your missing file error.

Yes I tried the second one and only gives the second error in the second picture.

Hope somebody here in this forum uses Fusion360 and can help.


It is the MAC part that is hard, Fusion and the PP work for sure on a PC.

I think this has to do with the filesystem, I am thinking MAC and PC will differ here so the output or something is hitting a snag.

No PC to output your gcode with at all?

1 Like

I can’t believe nobody is using Fusion in the Mac, I hope someone will fix that for us, just send a request in Fusion360 forum.


I use Fusion with on a Mac with the below PP. Only one I have tried so far


Hi Bryan, I found this one but there is no instructions on how to load in Fusion, I saw many lines and have no idea how to change for milling. Seem too technical to me… :frowning: If you know a link on how to change parameters and load in Fusion please share.

Just reinstall Fusion on my Mac and add the Post Processor from Guffy, my steps were add both files: “DIYCNC_Marlin20.cps” & “DIYCNC_Common.js”. I did not make any alteration only add and run the Post Processor, the error I got was:

[attachment file=120570]



I followed this to load the PP.

I have messed with changing parameters.

I tried to load the one from Guffy but when I tried to write out the gcode it did not write out. Where are the log files located to debug the errors?

1 Like

I followed this one as well, to difficult for me and I have no idea how to rewrite the g-code.


Hi Brian, had the same problem with my Mac, so I bought a PC and it works, have no idea why did not work in my Mac.

I downloaded this PP and was able to generate gcode after uploading DIYCNC_Marlin20.cps and DIYCNC_Common.js to the fusion ASSETS->CAMPosts cloud library.

I was able to tkdiff the gcode with the one from the prior PP and very similar. Will try running it later.

1 Like