Marlin 2.0 - How to disable Z homing when auto home initiated?

Hi there, I don’t have a limit switch on my Z axis, how do I disable the Z axis from homing when I send an auto-home command from Repetier or Lightburn? I just want X and Y axis to auto home. Thanks in advance!

Iz

I’m away from my MPCNC, so I cannot test anything, but according to the popup tip for LightBurn, the home button under the laser control just homes X and Y. There is an auto-home in LightBurn that homes when the software is started, but it can be disabled. On Repetier-Host there are buttons for homing just X and just Y. Plus you could add homing code to a custom button that does both X and Y but not Z. So from a practical point, there are already ways to home just X and Y.

But for safety reasons, you may want to prevent any Z homing in case you hit the wrong button. If you have a touch plate installed you can just make it a habit of clipping the alligator clip to the plate when you finish with it. Without a touch plate, you can put a jumper across the ‘-’ and the ‘s’ pins for the Z minus endstop on the control board. Or you can change the following line to be false in configuration.h and reflash the firware:

#define Z_MIN_ENDSTOP_INVERTING true

Any of these three methods makes Marlin think that there is a triggered endstop switch for Z when it tries to home Z. It will back off a few mm for a retest and then stop This will prevent your tool from crashing into your work. It will leave the stepper engaged though.

What I did with Marlin was define a custom menu item for homing only X and Y. It sent the code

G28 X Y

which basically says home X and Y only.

Using the “Auto Home” in the “Movement” menu on the LCD will attempt to home all 3 axes. I didn’t see an easy way to change that, since it’s just part of the standard menu screen.

Edit: And I keep the touch plate with the clip on the plate, and then have a magnet on the side of the machine that the clip is always stuck to when I’m not using the touch plate.

1 Like

I disabled Z homing in the marlin code for my MPCNC, let me see if I can find the post…

Edit: found it:

Thanks! So I’ve looked at that file and that code exactly like as you listed isn’t how it looks on my Marlin code. I’ll post how it looks on mine shortly.

I have Z disabled in Lightburn and I can confirm that the Home button under the laser control does indeed home my Z as well when I home X and Y. It moves the Z up only a few mm then homes X and Y and them proceeds to lower Z until it crashes into my work.

Are there buttons for homing X and Y alone? This seems like something that could be fixed in lightburn.

This sounds like a bug in LightBurn. I don’t use LightBurn as a g-code sender, so I’ve not had this issue. I don’t find any clean workarounds. It is possible to add start code to files, so you could add your X and Y homing to the start of each file. The three methods I list above will prevent the crashing, but the Z height will move slightly, and the Z stepper will be engaged after homing. If you have a display on your machine, you can use it for homing X and Y and avoid LightBurn’s Home. All ugly choices.

Edit: BTW, you can setup LightBurn so that your cutting is relative to the workpiece. It avoids the whole homing issue.

Yeah, I did this 3 years ago, there have probably been a bunch of updates to the code since then.
Just search for those 2 blocks of code, they should still be around somewhere :slight_smile: