Marlin compile and upload fails--MKS Gen L 1.0 (SOLVED)

My MPCNC is ready to start testing. I’m using the MKS Gen L with 8825s.

It’s my understanding that the RAMPS version of the MPCNC firmware will work with simply changing the board name. (I guess you also have to install the u8glib library which I have done.)

I downloaded the correct version of Marlin, installed Arduino and edited configuration.h file with the proper board name.

The verify process was successful. However, when I plugged in the board and tried to compile and upload to the Gen L, it failed with an error. No details

I need to acknowledge that I’m way out of my depth on this firmware stuff, so, I’m hoping someone can advise how to troubleshoot this issue or better yet, has knowledge of what’s is likely going wrong

Well, further investigation revealed a couple of things, and now, it appears that the upload worked.

  1. The serial port driver is apparently different than the standard RAMPs board. To be honest, I'm not sure this is correct because I've also been planning for an MKS GEN I upgrade to my printer, and I've never seen this issue mentioned. However, I did find a couple of references to the need to install the CH341SER drive from
  2. Of course, even that is not so simple, as Windows 10 has "protection" from unsigned drivers, so I had to temporarily turn off "Signed Driver Enforcement" so that this driver would load, which it did.
  3. Apparently, a suitable baud rate for the MKS GEN L board is 115200 instead of the default value. During one attempt to upload, the baud rate was overridden, so I just changed it.
  4. Finally, (and this may have been the most important??) I had not realized that the com port that was used did not seem to appear until the board was attached. To be sure, I don't know if changing that was needed or not--it may have been automatic.
With all this done, the compile and upload of the MPCNC version of Marlin seems to have been successful... Next step: see if the stepping motors will work.

Yup, you’ve found the right issues. :slight_smile: People run into a lot of the same issues with the clone Arduinos as well as with the MKS. They use the cheaper UART instead of the one specced. It’s normal for the COM port to only show when both the board is plugged in and the driver is installed.