Marlin firmware issuing Stop

CNC: Lowrider2
Controller: Rambo 1.4a (from Ryan)
Firmware: Latest Marlin DualLR firmware
Host: Repetier-Server (latest)
Post Processor: flyfisher 604 for Fusion 360 (latest) - removed M0 and G92 from gcode

The Drill operation, the 2D Pocket, and the Bore, all executed fine. The 2D Contour operation was cutting out the piece with tabs and had made the first 2 passes, each going down 6mm on a 3/4" piece of MDF. Then it stopped saying the firmware initiated a Stop. How do I debug this? Why might this occur. I could not see or hear a malfunction, and I happened to be watching it. Thank you.

Did the display give you any information about the error? As a first step, I rerun the file in the air (router off) and see if the problem is reproducible. If it is, and if the display or your g-code sender gives you additional information, take a picture and post it here. If the coordinates are being displayed, record them. You may be able to use them to locate the point in the g-code file the problem occurred and check to make sure there’s nothing funny in the g-code file.

I’ve never used it, but in searching for what conditions Marlin might stop, I ran into M999. It be worth a try since it could potentially save a job.

Though I don’t expect it to show anything, it is worth a couple of minutes to check your g-code file in a g-code simulator like this one.

The Lowrider2 no longer has a “Full Graphic Smart Controller, Big” attached to the Rambo 1.4a. It went bad and I replaced it with a 7" touch screen attached to a Raspberry Pi, which in turn is connected to the Rambo 1.4a. No error was shown on the touch screen, or on Repetier-Server’s web interface, merely that the firmware had issued a Stop.

I tried the " G-Code Q’n’dirty toolpath simulator" you suggested. It complained at the beginning that it did not understand M117, but that was at the very beginning and gcode was well along making cuts before the Stop. I don’t remember the exact numbers, but they were all positive. X was between 0 and 20. Y was probably less than 300. Z was between 10 and 20. I ran the Fusion 360 simulator for the gcode, which contained only the 2D Contour operation. It completed successfully. I looked for a simulator that was Marlin specific, but did not find one.

jeffeb3 mentioned my machine is larger than the max values in the firmware, and that caused the problem when homing. I was thinking this was not the problem, as the gcode had already traversed around the piece at least once, and was making its second or third pass (each cutting another 6mm deeper).

I would try rerunning the code in the morning, unfortunately the power company is cutting our neighborhoods power for 8 hours. I will try tonight.

If the problem occurs “in the air”, I could try rebuilding the Marlin firmware with the actual machine values and see whether it resolves the problem. Does Repetier-Server have a plugin that gives better error messages for Marlin firmware? Any other techniques for getting a better error message? I will also look in the gcode Console. Maybe something got dumped there that I did not notice. Thank you for your suggestions. I am SO close.

The machine values won’t affect movements, just homing.

1 Like