Max Endstops not working in Practice

Hey guys, I have just added x/y endstops (not dual) for my printer and it seemed to be working great until I found out that the max endstops won’t work when trying to go from the min endstop to the max in either x or y axis. I think I have enabled everything that should be enabled (code posted below) and running a M119 check tells me all of the endstops are working perfectly and as I want. The only thing that seems strange is that I have to press the x/y home button twice to get it to move all the way back to the min x/y endstop from the max x/y endstop. I’m running marlin on a RAMBo 1.3L with a 2ft by 2ft by 10 inche build area. Thanks for your guys help!

 

Code:

//============================<wbr />==============================<wbr />=================
//============================<wbr />== Endstop Settings ===========================
//============================<wbr />==============================<wbr />=================
// @section homing
// Specify here all the endstop connectors that are connected to any endstop or probe.
// Almost all printers will be using one per axis. Probes will use one or more of the
// extra connectors. Leave undefined any used for non-endstop and non-probe purposes.
#define USE_XMIN_PLUG
#define USE_YMIN_PLUG
#define USE_ZMIN_PLUG
#define USE_XMAX_PLUG
#define USE_YMAX_PLUG
//#define USE_ZMAX_PLUG
// coarse Endstop Settings
#define ENDSTOPPULLUPS // Comment this out (using // at the start of the line) to disable the endstop pullup resistors
#if DISABLED(ENDSTOPPULLUPS)
// fine endstop settings: Individual pullups. will be ignored if ENDSTOPPULLUPS is defined
//#define ENDSTOPPULLUP_XMAX
//#define ENDSTOPPULLUP_YMAX
//#define ENDSTOPPULLUP_ZMAX
//#define ENDSTOPPULLUP_XMIN
//#define ENDSTOPPULLUP_YMIN
//#define ENDSTOPPULLUP_ZMIN
//#define ENDSTOPPULLUP_ZMIN_PROBE
#endif
// Mechanical endstop with COM to ground and NC to Signal uses "false" here (most common setup).
#define X_MIN_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop. MPCNC
#define Y_MIN_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop. MPCNC
#define Z_MIN_ENDSTOP_INVERTING true // set to true to invert the logic of the endstop. MPCNC
#define X_MAX_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop. MPCNC
#define Y_MAX_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop. MPCNC
#define Z_MAX_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop. MPCNC
#define Z_MIN_PROBE_ENDSTOP_INVERTING false // set to true to invert the logic of the probe.
// Enable this feature if all enabled endstop pins are interrupt-capable.
// This will remove the need to poll the interrupt pins, saving many CPU cycles.
//#define ENDSTOP_INTERRUPTS_FEATURE

I’m not sure what you’re trying. Why have a max and min endstop?

How do you ask to home to max?

I’ve noticed during homing sequences that it sets a limit for how far to go before quitting. Maybe your have to set that for your machine? Did you set the bed sizes at least?

Where would I set the bed size in marlin? I’ve set it in Matter Control but that doesn’t seem to affect anything. I’m adjusting the movement until it quits position when homing right now and that hopefully should fix that issue. I’m just adding the endstops so that if my machine does decide to go past it’s build area then it won’t kill itself. I was just testing out going from min endstop to max and noticed that the max endstop doesn’t work when I do that. Thanks!

You need to set the bed size in the firmware, only if you have a min and max endstop, and have travel limits enabled, but really I wouldn’t bother this thing is so big if you screw up and go outside it’s bounds something else is probably wrong. They can be more hassle than they are worth.