MAXTEMP 3D Extruder Error

I have milling working great on my MPCNC. Now I’m trying to get the 3d printing working.

  • I have both sides of the ramps board powered via a jumper as in the instructions
  • I have the extruder nema stepper fan wired into the main green power ports
  • I removed the 100ohm resistor and plugged the thermistor from the 3d extruder (same model as sold here) into T0
  • I have the extruder fan plugged into D8
  • I have the hot end plugged into D10
  • I have B16_32_fullG-112515 flashed

When I power up the board (not connected to PC) it reports “Error: MAXTEMP” on the LCD. Same happens when I connect to computer via USB.

I then tried the Marlin_16_32_090615_therm firmware and it then reports “Error: MINTEMP”.

Shouldn’t this be displaying the room temp of the thermistor? Any ideas on what I am doing wrong?

Sounds like whatever hot end you got has a different value thermistor. I’m not sure how to verify that. Check to see if you actually do show a value of resistance. The little wires are delicate and easily come disconnected.

It is a 3950, 100k ohm type thermistor (, not sure why I didn’t just buy it from you. It looks like from the config it is set as the right type to load the right temp tables.

My multi-meter is acting weird and isn’t correctly reading resistance on the thermistor (or the spare one I have from the heat bed you linked to in your new 3d printer design or just any random resistor I have). I will pickup a new one tomorrow and verify that.

Thank you for such an incredible project. Have really had a lot of fun with this and appreciate all of the time you have put into this project!

Okay, so I tried out the thermistor from the heatbed (just connected to pins) and no error. I then noticed your setup for these imported extruders. I took mine apart as you document and I think the thermistor just had loose wires as you described. After I connected it all backup it worked great and is printing great! Thank you!