Mechanical issues vibration sounds and stutters

Hello Everyone… its been awhile, I was able to successfully build 2 MPCNC 3D printing machines with the common 30" x 30" square bed sizes…
I used them to print and build a fully functional BB-8 droid from Star Wars.
Configuration data:
Running latest RC8 with LCD (I use the LCD only now - no PC).
I am using all Vicious mechanical parts (bolts, nuts, bearings and steppers etc). I am using the RAMPS board which was also purchased by Vicious. I verified all Vref is set to .65 (have tried .55 and even .75 - too hot).

Here is my issue - I had the 2nd printer tore down for a bit and re-assembled it. I decided to update the new Middle section only (the corners and motor mounts are original versions).

Here is the issue… it is not smooth rolling along those axis… at first it was very tight getting that middle onto the original conduit arms (these are the C or 23.5 conduit). I rolled it back and forth on both axis for quite a while and it finally loosened up… (digging into the conduit making its tracks).

I noticed I kept stripping the pineapple connector between the stepper and the 5/16 (on the stepper side) and I keep re-printing this out and replacing… but its effecting the Z motion - almost seems like its moving it way too fast.

Photos: showing the print temp, and percentage being turned down to 80 to compensate and get better printing - howbeit issues mechanically still.

I also notice that unless I speed it down to 80% I get a somewhat decent print (there is still some issues with the infill not touching 1 edge of the sides from time to time).

I also tightened and loosened the belts to see if it made some impact…not much.

Here is a video of the printing of a part… at 80% still making crunching noise and not as much hardware issues running slower.
Mechanical Printing issues with MPCNC and C middle

What could be causing the vibrations and stickiness on the middle when it tries to move… it gets caught up or it moves fine… its random.
Lessoning the speed means that I am printing too fast? I am using the firmware suggested by Ryan to print with… unless that is for the CNC side not the 3D side?

Need insight as to where I can go from here.


The RC8 still has issues they are fixed in the bugfix branch but I can’t update it today.

You should try the RC7 firmware.

As for your tight pieces, the middle bolt with the plastic on both sides still controls tension. I usually leave those very very loose. If you follow the instructions I think it walks through the canter tuning pretty well now.

Thanks Ryan… yes I left it loose… I cut the ties and reset the GT belts… on both sides for both X and Y…
I started a new print towards the center of the platform - note my Z is only 4" tall legs now… so its like what you suggested.

Here is the photo of the not reaching the edges on the first layer… you can see it around the circles (holes) especially)… the outer lines though look very good and clean extrusion…

maybe I need to re-adjust the 123Design configuration to work with this? or just try RC7 first?

See attached photo of first layer



How fast are you printing? start at about 30mm/s

Current settings are as follows (of course on the LCD I turn it down to 70% or 80% for test now)

Retraction Distance 2mm
Retraction speed 4mm/s

Nozzle Diameter .40mm
Extrusion Multiplier .90

Primary Layer Height .26

Solid Layers
Top 3
Bottom 3
Parameters 2

First Layer height 124%
First Layer Width 100%
First Layer speed 50%

Default Printing Speed 60 mm/s
Outline Underspeed 50%
Solid infill underspeed 60%

x/y axis Movement: 55mm/s
Z axis movement: 16.7mm/s

Have you seen my settings?

Those are all over the place try something like this.

Retraction Distance 1mm
Retraction speed 30mm/s
Nozzle Diameter .40mm
Extrusion Multiplier 1
Primary Layer Height .26
Solid Layers
Top 3
Bottom 2
Parameters 3
First Layer height 100%
First Layer Width 120%
First Layer speed 40%
Default Printing Speed 30 mm/s
Outline Underspeed 90%
Solid infill underspeed 100%
x/y axis Movement: 55mm/s ???not sure what this is. if it is “travel” that setting s fine
Z axis movement: 16.7mm/s 2 times maximum speed try 7mm/s

Understood - made the changes (yes the 120% etc was interpretation from slic3r settings)… but the overall speed of 60% was to mimic my reprap… :slight_smile:

Uploaded RC7 firmware - leaving all the defaults as you set

Started another print… very slow but… notice the first layer infill is now not connecting (gaps between the lines) and the circles there is a gap to the infill and the outer edge again… maybe increase infill overlap from 15% to 20%?

That is not what that setting means, keep going see what it looks like 20 layer high or so.

That just looks like you are too high off the bed

You changed all the setting right?

Why not try slic3r with all my settings… then when you get it working you can try other slicers. It is very difficult for me to help with other software.

Ok will switch back to slic3r first with all your settings…
I will start another print and report back… yes you are correct on being too high, one corner starting lifting (warp).


Ok opened up ole slic3r and re-verified all screens (although newer slic3r the later extruder screen has newer options) match your defaults…

Took that object and sliced it to gcode.

Tried to print… Got good bed adhesion but same thing again… Although really watching the print, you can see the middle and head jerk along as it tries to move in angles and straight lines… almost like its fighting the pipe.

I went out and purchased 2 new 10’ 3/4" EMT and cut em up… yes I did :slight_smile:
I replaced all gantry with new pipes…
reconnected the belts

Now… when I print, its the same thing… its like shaky as it moves and seems to fight.

I guess the next question is: What is a good method of putting those belts on… lets say I am looking at the printer from the front of the printer (where X is facing me). I pulled the middle all the way to the end and put the belt on the Y left side corner. I ran it through the Y left side motor and connected it at the other end… but maybe its an alignment issue (I am keeping it somewhat loose where its tense enough to be straight but flops around as the motor moves along it).

I then (while its still in this position) connect the belt on the right side and run through the Y motor on the right… keeping it the same… HOWEVER - as I move this bar forward and back its like really making that rough noise like its fighting the belt… or not turning well on the belt… but my other MPCNC does the same thing and works fine.

Could it be:
vref on this machine (currently at .65) needs to be turned up/down?
I am doing the belts wrong?


The belts take no special setup, just try and get the tension the same. It sounds like you rolling parts are just too tight. Take the roller motor mounts off or loosen them and pull the gantry off. see if each roller is moving smoothly along all the travel and loosen the tension bolts as much as you can and still have the bearings touching…usually all the waay loose on a new machine. The do the same for the center the x and y conduit roll smoothly all the way along? are they square, use something square to verify.

Make sure things are as loose as you can get them with them, and make sure you are not rolling one of the bearings on the rough conduit seam.

Ok I think your onto something sir… hey can you explain what tension bolts A and such are? is tension A the 1.5" and the tension B the 5"


Any bolt with plastic on both sides of the bearing has some degree of tension control.