Mega Problem

My parts bundle arrived yesterday! While my parts are printing, I am doing other things in preparation for the build. I tested the RAMPS/Mega board by connecting 3 stepper motors, resistor and pugging in the power supply. I can’t get a serial connection to the Mega from the Arduino IDE, and I can’t connect to Repetier.

I have another Mega not being used right now, so I loaded the RAMPS-RC firmware downloaded from the link in the Assemblies page. I can connect to the Arduino IDE Serial Monitor, and I can connect to Repetier. I can control all three X, Y, and Z axes. The RAMPS Board is good, so it must be the MEGA.

When I connect the Mega (from the Parts Bundle) to the USB, it’s recognized by Windows, and it has a port number. The two red LEDs labeled L and ON both light steady. The error I get from the Serial Monitor of the IDE is “Error while setting serial port parameters: 250,000 N 8 1”. If I press reset, I will get some gibberish in the serial monitor (like when the Baud Speed is set wrong). I did a visual inspection of the Mega, top and bottom, and I don’t see any bad solder joints or any other visual damage.

Has anyone seen this, and is there a way to fix it?


I test every single board that goes out on one of my machines, every stepper. Does the arduino get assigned a com port under device manger? Does it work if you do not have power plugged into the ramps shield?

Try pronterface, and see if it changes anything.

Yes, Windows sees “RAMPS (COM6)” without the shield connected. With RAMPS shield on, no power plugged into the ramps shield, Windows sees RAMPS (COM6).

I have loaded and started Pronterface , plugged in the power supply to RAMPs (USB connected). I selected COM6 @ 250000 and I get this error message “ValueError: Cannot configure port, some setting was wrong. Original message: [Error 31] A device attached to the system is not functioning.”
Here is the entire text:

Traceback (most recent call last):
File “printrun\pronterface.pyc”, line 1053, in connect
File “printrun\pronsole.pyc”, line 720, in connect_to_printer
File “printrun\printcore.pyc”, line 46, in inner
File “printrun\printcore.pyc”, line 197, in connect
File “serial\serialwin32.pyc”, line 31, in init
File “serial\serialutil.pyc”, line 261, in init
File “serial\serialwin32.pyc”, line 71, in open
File “serial\serialwin32.pyc”, line 186, in _reconfigurePort
ValueError: Cannot configure port, some setting was wrong. Original message: [Error 31] A device attached to the system is not functioning.

When I connect my other Mega to the RAMPS shield, plug the USB and Power the RAMPs board, change the COM port, it connects and drives the stepper connected.

Here it the text:

Printer is now online.
echo: External Reset
Marlin 1.1.0-RC3
echo: Last Updated: 2015-12-01 12:00 | Author: (none, default config)
Compiled: Feb 2 2016
echo: Free Memory: 5330 PlannerBufferBytes: 1232
echo:Hardcoded Default Settings Loaded
echo:Steps per unit:
echo: M92 X80.00 Y80.00 Z4000.00 E500.00
echo:Maximum feedrates (mm/s):
echo: M203 X300.00 Y300.00 Z5.00 E25.00
echo:Maximum Acceleration (mm/s2):
echo: M201 X3000 Y3000 Z100 E10000
echo:Accelerations: P=printing, R=retract and T=travel
echo: M204 P3000.00 R3000.00 T3000.00
echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
echo: M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00
echo:Home offset (mm):
echo: M206 X0.00 Y0.00 Z0.00
echo:PID settings:
echo: M301 P22.20 I1.08 D114.00 C100.00 L20
echo:Filament settings: Disabled
echo: M200 D3.00
echo: M200 D0


Is that an USB 2.0 port on your computer?

Yes, USB 2.0 port. I’m using the same ports that I always use for Arduino’s. I have a few dozen Arduino’s :slight_smile:


Assuming you haven’t solved this issue or for those that come along after I’ve had this happen on a few occasions when building various printers and most recently the MPCNC.

Try dropping the Baud Rate to 115200 and see what happens. I used a cheap clone for this build and it couldn’t handle the higher baud. Once the baud rate was adjusted, I was able to continue on without issue.

Thanks, I just used another Mega. It will sit on my shelf until I get the urge to fix it :slight_smile:



I too got a “bad” Arduino Mega with my first parts bundle. I had another Arduino Mega (original) that worked fine so just put the “bad” one off to the side and used mine. While building the next MPCNC, I again picked up the “bad” one… and again it didn’t work. Not having another on hand at the time, I noted that it was a “clone” and googled around a bit and found that many cheap clones do not use the standard serial to usb chip original Arduinos use. They use a chip marked CH340 and your computer will not recognize these CH340 chips until you download a proper driver. The following Instructable (and several other sites) describes the problem and fix… it worked for me and I’ve had no problem since.

– David

What operating system and what version?

I have a windows 7 and 2 windows 10 and never installed anything other than arduino.


I’ve used an old Acer laptop running XP to initially run my MPCNC’s. I had to “manually” hunt down that driver and once installed I’ve had no further difficulty. I don’t really know if later versions of Windows and/or Arduino IDE go find it “automatically” but that’s what it took for me. I swore that first Arduino MEGA was bad and had put it off to the side but I also knew you had pre-loaded it so gave it another shot. It worked for me. – David

I need to put that link somewhere, Thanks for finding and sharing it.