Mini-Rambo and LCD Screen


and thanks for your time in advance.

After assembling the mechanical parts I am now stuck at assembling electronics/managing the software for quite some time.

My problem is maybe connected to these two issues:

I tried the solution multiple times. I am now quite sure, that the connection Mini-Rambo to LCD board is correct, since it is the only combination where the display lights up and the lcd board's reset button issues a reset signal.

The Board was purchased from here:

Uploading the firmware issued no problems or warning either, not on Linux and not on Windows. I first tried Arduino version 1.8.10, after that according to the solution mentioned above I tried Arduino version 1.8.9.

Following steps over all

  • downloading and installing arduino software
  • downloading Marlin-MPCNC_MRambo_T8_16T_LCD firmware from github
  • starting arduino and adding the link to the package_ultimachine_index.json to preferences
  • adding and selecting the board "RAMBo"
  • adding library "u8glib" in library manager
  • opening Marlin.ino from the firmware mentioned above
  • change view to "Configuration.h"-tab (4 tabs open)
  • connect Mini-Rambo to power and to usb port (LCD board not connected to Mini-Rambo)
  • select it in arduino port selection (is recognized correctly)
  • (validate and) upload sketch
  • disconnect Mini-Rambo from usb port and from power
  • connect LCD board to Mini-Rambo (have tried all different combination of port and orientation)
  • reconnect Mini-Rambo to power (12V, 6A)
Some strange messages in arduino serial montor and in pronterface, when trying to connect, as shown in the pictures attached.

I don’t know, what I should do next to reduce the number of possible problem origins. Maybe someone is able to help.

Thank you all for your time in advance!


Reflashing about 20 times with no changes to the process whatsoever now worked out as planned: No more strange messages in Pronterface and other programs. The last walkthrough was with Arduino Version 1.8.10 and the steps above, without connecting the lcd board and longer waiting (2-3 minutes) before changing connections. So after “upload done” is shown in the arduino software, I waited a few minutes, before disconnecting the Mini-Rambo from power and the usb port. Now the messages displayed are “correct” or at least understandable, except of some errors, but controlling the steppers works as intended, which is by far the most important part to me.

The display does still not work as intended.

Is there a chance, that I am just using the wrong type of LCD-Board? Honestly, it was a guess that most LCD-Boards with the same components (screen, knob/button, reset button…) work pretty much the same.

Is there someone using a smaller LCD-Board as sold in the shop and used in most builds? One of the size I am using (as shown on the pictures above)? If yes, is it working?

Or are there good chances, that it will work with a board like that:

Greetings and thank you for your time.

Wild guess, but I think you may have configured your firmware for the full LCD, not the small LCD. @jeffeb3 or @vicious1 could certainly confirm (as could others, I’m not trying to knock anyone).

edit: The LCD you linked to is the “full LCD” of which I speak… :wink:


Thank you for your reply.

Yea, I guess I will purchase one of the full LCDs (one can never got enough of spare parts) and while waiting for it to arrive, I will take a deeper look into the configuration.h, since there are some lines, that may be intended for the use of a smaller LCD.

Yep, that LCD is different. In the firmware, this is set: REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER

If you post a link to your LCD, we might be able to tell you what steps to take to get that LCD working.

And I appreciate the diligence trying to get the flashing right, but they are really robust and if there aren’t any errors printed, then it probably worked the first time, and it takes about 15 seconds or so. When it says, “done”, it’s actually done. No unmounting or syncing required.

1 Like

I think it’s this one:

You’d have to remove the ‘//’ at the beginning of this line, and put them at the front of the other one (line 1877).

1 Like

The link he posted implied that it’s a 2004A LCD (?) with the RAMPS 1.3 controller… I’m guessing this is the right course of action. (Note that I said “guess”, and that I’m not nearly qualified to actually suggest a reasonable course of action)

1 Like

Thanks for your help. Because of the cryptic messages, shown in the last two pictures of the first post, I thought there was a problem with the flashing process. Wouldn’t have guessed, that these messages appear because of the wrong LCD-setting and I am still not sure about it.

However it was just stupid of me, not to look into the Configuration.h in detail, since it is extremely helpfull, very well structured and very well commented and a short look would’ve been enough, to see quite a few options for many different displays.

I will try to confirm as the correct setting as soon as possible.

Thank you two for your help so far!

EDIT: Display and steppers are now working absolutely fine. Thanks again!


The serial monitor and pronterface are maybe just the wrong baud rate? Otherwise, arduino is in German :), but it looks right to me. You definitely should “disconnect” the serial port from pronterface before uploading, but it should be ready as soon as it’s done.

1 Like

The baud rate might be the correct problem source, I changed it in one of my later iterations of flashing. Although I did not change anything in the arduino settings, only in Pronterface.

I will try to recreate the problem as soon, as I’ve time and leave another post if I find out, what I did wrong and what caused the cryptic messages.

However, as edited into the older post, I am very happy that the display is working absolutely fine now, although I won’t be able to enjoy the nice bootup-screen …

until I got myself one of the bigger displays :wink:

Thanks again, you two, for your help!