Mini Rambo swap z and y

Is there any way to swap the z and y and use y and extruder with endstop to auto level z and manually adjust y on mini Rambo

If you just want to have dual endstops on Z, then you don’t have to swap anything, just enable DUAL_Z_MOTORS and DUAL_Z_ENDSTOPS in Configuration_adv.h. That’s for homing to Zmin. If you need to home to Zmax, then there’s a little more to it.

1 Like

Oh, and you have to disable the E0, by moving it’s pins to something else and then make a dummy E1 with the pins from E0.

that’s what I thought I was confused on how the stepper driver was able to stop output to one motor while still powering the other being as there is only one driver and 2 outputs so z y and x can all essentially home to the min as the home im just tired of squaring it all up before each cut

Right. There are actually two features here. Dual motor gives each motor it’s own driver. But that’s not necessary. Dual endstops only does one thing, and that is allow the motors to move independently when they are homing so they each hit their stop exactly. Dual endstops only works if there are dual motors.

But the mini rambo has only 4 drivers. You can only do that on one axis.

I’m confused the z axis is series to 1 connector how AR the motors being limited wouldn’t you have to separate the z to independently stop each motor

Yes. You can, with some work, connect one Z motor to the E0 port. Then attach separate endstops.

Hi, I am trying to enable dual z motors and end stops for my lowrider with mini-Rambo also. I see in the Congifuration_adv.h where to enable these, but I am confused by your following comment regarding “disable the E0 by moving it’s pins to something else and then make a dummy E1 with the pins from E0.” I hope I’m not getting in over my head, but I’d really like to get this set up as I have trouble keeping my Z axis level. Can you please elaborate about E0 and E1 for a newbie? Thank you!

It is advanced, which is why Ryan has done the work for us in the other dual endstop configurations. The latest versions of marlin will work if you set EXTRUDERS=0, but there has been very little testing in the real world of this.

What I was suggesting is, You go to the pins mini rambo file and

  1. Copy everything from E0 and make an E1 entry with the same pin values.
  2. Set all the E0 values to 70.

The firmware is kind of dumb, and even if you have EXTRUDERS=1, it won’t touch the E0 pins unless you command an extrusion. So setting them to something valid, but wrong is ok.

It will then think you have an E1 port, which is where it would like to send the Z2 signals to. The E1 pins are now set to the values of the E0 port. So Z2 has now taken over E0.

It is a neat little hack that Ryan came up with. Hopefully, EXTRUDERS=0 will make it obsolete, but that is TBD.


Thank you so much for the explanation. That was very helpful. I just built an MPCNC with Rambo and dual end stops and it works great. I was hoping to drive the Z motors on my Lowrider2 independently and with your help I think I understand now. Thanks!

I have made the changes to the firmware and all the motions work. I just got my limit switches today, I assume I install these as NC and connect to the S & - terminals for Zmin and Xmax correct? If so, what command do I issue to cause the Z motors to home to open the limit switches? I believe that Home Z Axis (under custom commands) is typically used to close a connection between the router bit and a conductor on the workpiece, is my understanding correct? If so, then how do I auto-level Z after making the changes described above? Thanks in advance!

You’ve got several things going on here. Are you trying to home to -Z or +Z?

I haven’t got the magic sauce for keeping probing and dual z endstops working. I assume it is possible because there is an option to make the probe pin the same as the endstop pin.

Sorry, I wasn’t clear. I am only trying to enable dual z endstops. I assume that after making the changes (e.g., enabling DUAL_Z_MOTORS, DUAL_Z_ENDSTOPS and USE_XMAX, defining the E1 pins and setting E0 pins to the dummy value of 70) I should connect my 2 limit switches to the Zmin and Xmax (s) and (-) terminals for NC switches. The switches should open when each Z end finds it’s min position. First question, is my understanding so far correct?

Assuming I followed instructions correctly, my second question is how to I initiate the Z axis homing? Is it as simple as using the Home Z Axis custom command? Forget what I said about the z probe stuff… my real questions was how to initiate Z homing. Thanks!

The NC vs NO is set by an inverting flag for each endstop. You can check with M119. It will show you if they are triggered.

Home Z is right. It will send G28 Z. But don’t try it until you’ve confirmed the behaviour with M119.

1 Like

Thank you!

Thanks for the advice about testing with M119… I can’t figure out why my Z2_MIN is always triggered. Z1_MIN works as it should. My understanding is that the Z2_MIN is set to use XMAX. When I connect my limit switch to (S) & (-) on Xmax on the Mini Rambo, I can’t change the state of the Z2_MIN. Any thoughts or suggestions?

It might be zmax. For mpcnc dual endstops i think it uses min and max for x1/x2 and y1/y2.

Then if you want a probe you can use xmax which is the only one left.

1 Like

Thanks. One of the configuration settings in the enable dual z motors block has a definition to use xmax for z2_min. I can try using z max and see if that works. I’ll try out tomorrow.

Yeah, I would have guessed Zmax. I think it is defined in the configuration adv, but it might be redefined elsewhere.

The Z2min pin is assignable. In the code as downloaded, it is assigned to use Xmax. I tried this and I tried changing it to use Zmax – neither worked. I have dug into the code and I think that with Z2min assigned to use ZMAX, the endstop code should be looking for the state of pin 23 (assigned to Zmax). I don’t know which pin is 23, I assume it is the (-) pin in the Zmax group as shown in the mini Rambo diagram. In any case, I can’t seem to get the Z2 min trigger to work as it should.

Has anyone gotten this configuration (dual Z endstops with mini Rambo) to work before? If so, I’m obviously missing something… Should I buy a Rambo board and start over?