MK8 extruder initial setup issues

It’s been a while since I started this project, but I finally have time to focus on it. I ran thru the crown simulation with a sharpie, and it looks great. Now I’m trying to get the extruder set up.

I’m using linux, which has made everything a little more challenging. Repetier software is working well. Rambo 1.4a board, Marlin 1.0 from what repetier tells me.

I’m getting the Error:Heating failed, system stopped ! Heater_ID: 0

Initially it had no power, so I wired it straight to the psu, it got hot and smoked a little, so unplugged it. I upgraded the wire to 14ga off the psu, and now it heats up wired off the board. Maybe that’s a fluke, not sure, was using 22ga wire off the psu originally.

The temp on repetier always shows 170. All of my hardware is from here, so I think it should be set up initially. I’m not sure how to check the thermistor 11 setting. The wires from the thermistor look good as far as I can tell. Wired into T0, and tried flipping back and forth.

Manual testing gives the heating error after a few seconds, but it does get warm. Fans and steppers all move manually just fine.

I read a few similar threads, but got stuck here. Any help is appreciated.

Heater 0 is the hot-end, and since it gets hot when you send it current the failure is probably due to not getting a good temperature reading. This is an important safety feature of the firmware.

Since the display doesn’t change when you heat the extruder I suspect a bad thermistor or problem with the connection. Are you sure the thermistor connection is plugged into the right spot on the board? (I don’t use that board so don’t want to try and judge from the photos). Is the connection between the thermistor itself and the extension that runs to the board reliable?

Second, can you use a meter to test the thermistor? Set to Ohms you should see a change in resistance from room temp to holding the thermistor between your fingers, or from touching the heat block (without the heater on) if the thermistor is already installed and hard to remove.

The default CNC firmware does not read temperature. You need firmware for the 3D printer. We have dummy thermistor setting (998) in the cnc rambo firmware.

I checked the resistance, 100k ohms at room temp. I just heated up the extruder for 2 error cycles, and the resistance dropped significantly. It looks like it’s working as expected, good idea to test that. Thanks.

I’ll work on updating this tonight. Thanks for the confirmation.

Would I need to change the firmware again if I go back to a cnc setup?

Maybe. I think newer firmwares are ok with not checking the temperature until you try to heat the hotend. So it may be fine. Otherwise, you’ll have to leave the extruder connected.

Ok, firmware updated to Marlin 2.0 from github, V1CNC_Rambo.

I modified the firmware per the import-extruder link I can’t post. Here are the changes:

#define TEMP_SENSOR_0 11

Constant updated to 11 from 999

#define DEFAULT_AXIS_STEPS_PER_UNIT   {200,200,4535.44,200}

Numbers updated here

#define PIDTEMP
#define BANG_MAX 255
#define PID_MAX BANG_MAX 
#ifdef PIDTEMP

ifdef PIDTEMP was the only missing line here, but it crashed on compile so I removed it.

Can you confirm this is the correct firmware? and correct changes? A few things are broken now, but the original error is gone.

Heating the extruder no longer heats. The red light does not turn on anymore.
Turning on extruder temp: echo:Unknown command: “M104 TO S200”
Turning off extruder temp: echo:Unknown command: “M104 to S0”

Temperature from thermistor shows 0.00C now, but it’s definitely warmer than that, even tho there’s no power to heat.

The E0 stepper no longer moves. It just prints X:0.00 Y:0.00 Z:0.00 E:0.00 Count X:0 Y:0 Z:0
X, Y, & Z axis all still move, and they do not print any information to the log.

Rebooting the controller prints a bunch of stuff, but specifically more unknown commands; “M80”, “M221 S100”.

Let me see if I can make this easier. We didn’t have a full sized rambo extruder config until recently, and it hasn’t made it into the releases (it should be in v510). But there is a build that should work, but the link is a little funny:

https://github.com/V1EngineeringInc/MarlinBuilder/suites/1955165809/artifacts/38730629

I think you will have to log into github for that link to work.

Otherwise, I’ll ping @vicious1 about making a v510 release and we might have that up soon.

Perfect! that did it, thanks. I made my first plastic spaghetti!

The temp sensor is working now with the default settings in the file you posted, TEMP_SENSOR_0 5 instead of 11. I’ll have to work on the heated bed next. I may tweak the steps per unit from default, it seems a little jarring in the x-y axis with 100.

I originally wanted one machine to do everything, but I’ll probably end up with at least 2. One dedicated printer, and one for cnc. I’ll use this setup to print the dedicated printer.

Since this is related to the firmware linked here, is there anything else to change for a heat bed?

There’s no heat to the bed, and no temperature from T1 bed thermistor. Repetier thinks there’s no bed, but if I reboot repetier it shows up. Enabling the bed gives a fatal error: MINTEMP triggered, system stopped! Heater_ID: bed. Emergency stop removes the bed from manual control in repetier.

The TEMP_SENSOR_BED was already 11. The extruder TEMP_SENSOR_0 reads with either 5 or 11. I swapped thermistors, and both read 20C when plugged into T0.

I confirmed 12v power to bed, continuity on bed heat loop, T1 thermistor has 100k ohm reading, and 15 amp fuse is continuous. Anything else to check?

Hmmm. I am not sure. This config should be very similar to the mini rambo mp3dp, which has lots of testing. But no one has tested this specific software. Your guess is as good as mine.

Figured I’d give each thermistor port port a try. For whatever reason T2 is the correct port for the heated bed thermistor, according to the reprap rambo diagram. Power turns on and displays the temp now.

It’s a bit weird - Heater 0 and Thermistor 1 are for the extruder, Heater 1 and Thermistor 2 are for the heated bed.

edit corrected Heater 1