mk8 hotend never switches off

I've got everything build on my mpcnc, seems good, got movement xyz etc. I've installed a heated bed and mk8 hotend, I'm using octoprint to control, via rpi, I can heat up the hotbed fine, but my problem is if I start heating the hotend it never switches off.
Initially the problem was the hotend hadn't been uncommented in firmware and the defult temp of 170C was used. When I first tried this I didn't switch it off straight away, and it got red, not good, of course I switched it off straight away.
Now thats the hotend and temp are setup in firmware and even though the temp of hot end is tracked upto target temp it never switches off, and just keeps rising, so I turn it off myself.
I read it might be that the mosfet got blown ? I don't know, anyway I tried it in the 2nd hotend position, enabling 2 hotends in marlin, re uploading and moving all the plugs (hotend, fan, temp sensor) to the hotend 1 position. Anyway I get the same behaviour, basically the temp of hot end never cuts off at the target, so I cut it before it reaches too high.
Any suggestions where to look, or what I might be doing wrong ? I'd be surprised if I'd blow 1 mosfet, let alone on both hotend controls, so there must be something else I'm doing wrong.
[attachment file=54823] [attachment file=54824]

Configuration.h (57.5 KB)

Line 134 should be 1 not 2.

Line 238…1? 11 is the right one for the hotend I sell, and you bed temp probe is a 60? for me usually 11 is again the correct number.

If you are unsure you should put up some pics of your equipment or look it up from where you bought it.

Thanks for looking at the config file.


As I said I tried the second hotent positions to see if they had the same behaviour, which they did, i.e the temp just ran away and didnt’ cut off when it reached the defined limit, the temp was reading correctly. I was testing if something had gotten blown, perhaps grasping at straws, but wanted to eliminate things. Thats why the config has the second hotend line 134 enabled, but in the pictures I’d already moved the connectors back to the hotend 0 position, I just hand’t changed back the config file.

I didn’t buy the heat bed from you, just the hot end, rambo, and other parts, but as I said the heated bed seems to be working ok. I found the mention of 1 for hotend from a place on the net with the same hotend, I’ll try 11 though.


Although I’m confused, because a temperature value was being shown, and increased as the hotend was heating, but the temperature just wouldn’t shut off.

I’ll try your 11 value for temp sensor, and report back. Thanks