MKS Pro 1.2 with cnc.js

Hi all, I have been using MKS 1.2 with my PI and cnc.js for many weeks and all was working fine.
Today the “com” port is dead on the MKS. I have tried to change usb cables, updated the firmware with more. USB Still dead. I can use the touch screen to move the axis so rest of the mainboard is fine.
Found in a comment on the web. PI and MKS. The MKS dont like the voltage that PI is sending out. And the USB port dies, one said it had happend to him two times, and he stopped using the PI.
Using the PI 4B 8Gb version.
Anyone else had problems with the MKS and Raspberry PI.

That’s strange. Does it have anything in dmesg after you plug it into the pi?

Do you know what usb chip it has?

Does it work connected to a computer?

I tried to change to the computer (win 10) I have Repetier-Host set up. Still no response. The com emulation dont happen.

From PI just now.
687.671072] usb 1-1.1: device descriptor read/64, error -32
[ 8687.891142] usb 1-1.1: device descriptor read/64, error -32
[ 8688.110860] usb 1-1.1: new full-speed USB device number 5 using xhci_hcd
[ 8688.211250] usb 1-1.1: device descriptor read/64, error -32
[ 8688.431098] usb 1-1.1: device descriptor read/64, error -32

AFAIK status -32 means “Broken pipe” (EPIPE). It means that there are problems with usb communication (protocol). For example usb-device doesn’t answer correctly for usb-request, and sending some data that are not expected by host or sends not enough data. There may be also other reasons.
I have tried 4 different USB cables and PI and PC have same problem. (I think) there to be something wrong with the MKS. And again this setup has been working fine for a long time.

You can configure the pi to use a raw uart. You’d need to enable a serial port on the mks, and disable the other users for the serial port on the pi.

I haven’t heard of this issue before. Do you have a link to more info?

Dont have any technical information. Did a web search and found some reddit posts.


I have tried to troubleshoot = google :slight_smile: Dont find any technical clues what is going on. I ordered a spare board some weeks ago, should be here soon. And I will order one more today. Will continue to use the PI. And if other breaks I will try to switch to only PC and see if it happens again.
I love my mpcnc primo and the ease of using the PI with cncjs. But my 800x800mm machine is getting “small/slow” for some of my projects. So I have started to order parts to build the Avid pro4896. with close loop steppers (nema 34) and a Centroid controller. Will still use my mpcnc for all the small cuting/engraving and laser projects in the future.
1 Like

I would consider buying a different board :smile:. Sounds strange.