Motor direction problem

I use a RAMPS 1.4 with 5 DRV8825, each one for every stepper. My steppers are rated to 2A, so i will drive them with about 1.6A, therefor i can not parralelize the two correspondig stepper of X and Y axis. So Repetier is configured to clone X signals to E0 and Y signals to E1.
Since the steppers are turned 180° one stepper connector is also turned to invert the direction.

Now the issue: If i move X+ both go in the X+ direction, if i go X- the X stepper inverts the direction (as it should) but the E0 Stepper still goes in the X+ direction. Already swapped out the RAMPS and the stepper drivers. No success. If i connect the steppers to Y and E1 everything is ok, direction is changed as it should.
Also tried Marlin, but i can not get Marlin to clone X and Y cause Marlin only allows to clone to the next free “E”-Port and E0 is already used by Extruder one. So i cloned X to E1, and there is the same issue! Now i have no clue to cope with this issue. To connect the steppers parallel they draw to much current for a single stepper driver. If nothing helps i will have to wire the axis motors in series, but thats not really what i want to do…

The new marlin firmware has more settings for axis cloning. RC7.

But really series works like a dream, it is the correct way to do this. No chance of 1 axis losing a step, no need to waste your driver ports.

already tried RC7, but imho Marlin assumes you have at least 1 Extruder motor connected, so much edit would be needed cause it would map X to the first free Extruder port, which is E1 and Y to E2 which does not exist in RAMPS_Config… So i will go for series steppers. Don’t know why its working on Y E1 ports and not on X E0 ports…

Sorry I thought RC7 had made it very easy in the advanced config tab, but I didn’t dig very deep so I’ll take your work for it.

You should really just wire it in series, It is very easy and in my opinion the right way to work two steppers on the same axis.

Are you still using 12 volt as power supply with series connected steppers?
Not shure how it works with steppers but normally if you put something in series the voltage drops in half and in this case 6 volts instead of 12 volt.
My steppers also have a max of 2.6 amps (4.8kg)
Also planned to use 1 drive for each stepper set at about 1.75 amp.
Another thing that could also be a possibility is run at a higher voltage like 24 volts, haven’t researched it yet with ramps but it was in the back of my mind.

Since the cnc will move quite slow, the voltage should be ok. Steppers are rated at 2A @ 2.8V the 6V should be fine. To get Ramps to 24 V there are some modifications required, else you will fry the voltage regulator of your Mega.

“Y to E2 which does not exist in RAMPS_Config”

Yeah, that stumped me for about 10 minutes, wondering what were the Marlin people up to! Then I duplicated the E0 config pin section and replaced the new 0’s with 2’s. (Actually, I think I copied a different section, but ended up with E2’s… I also used different pins because I’ve added a small separate single-driver breakout board to my RAMPS so I can also have an extruder. Cost about $15.)

Edit: Just a thought, about changing stepper direction, I was used to commenting out things in Marlin and other firmwares but I think that needed false changed to true instead.

Might need to change the pins on E0 if you are using this trick to create a new E2 driver that maps to E0…

no more need for this, will stick to estlcam firmware, which is playing flawless. On ramps with 5 stepperdrivers, on Uno with 2 motors in series, both work like a charm