Motor extruder stuttering even without filament

Hello I bought the ramps here but the extruder not. I have everything working correctly but now the extruder is the problem. There is not coming any filament out. I have opened the extruder and tried several things with and without filament and saw that the motor is stuttering/ jammed/ clogging. Even if i pull it completely open so that nothing is hitting anything the motor still stays on the same spot and moves left to right: nothing more.

However, if i say in repetier to pull out 100 filament everything works fine! But the test file that you gave the motor is stuttering/ clogging again. Am I missing something?


  • checked everything and everything is working if I put code in to extrude 100 filament (repetier)
  • If i put test file from: 3D Printing / Import Extruder | V1 Engineering Inc then the motor doesnt move/ starts stuttering/ clogging.
  • If i output 100 on repetier then it outputs ± 3 mm. Maybe this is the problem? But i don’t see anywhere that i need to calibrate it.

Before i brake anything editing software: Hope you can help me :slight_smile:

Did you adjust the vref on the drivers? Should be half the rated current if the stepper. When I first started, mine was way too high and I overheated everything and the prints got all weird looking.

I think it is, since i bought the board with RV8825 drivers from this website. And the output is working fine if i only use the motor with 100 extrude, but when i put the test file on it’s clogging/ stuttering and most of the time it won’t even output anything. U can still push the filament through though. X, Y an Z are working perfectly too.

Tried to make a video today, but it’s not the lightest place. Try to make a video again tomorrow. Hope u guys can help me fix it, can’t see what I’m missing.

Double check the vref with a multimeter. I bought the board here but the mk8 somewhere else, and the default vref is way too high. Mine is at .85 but default is like 1.6v. If u made sure, then check your slicer settings.

I think your right, tried to turn the screw as described in this video: - YouTube
Still need to install the headbed, everything is curling. But first waiting for someone that has a multimeter and can help me with this :slight_smile: (0 knowledge about that stuff)Slicer settings and other setttings are correct.

Thanks in advance, and if it’s still not working after that then you hear it from me