motor problem

I just got my mpcnc put together, and was using repetier to jog it around to see if everythign was moving properly. The Z axis worked fine, but the X and Y axes weren’t moving properly (lots of vibration, often not moving). I had also switched the X and Y axes around, compared to how I wanted them set up. I depowered everything and switched the wires for the X and Y. when I started everything back up, and tried jogging in repetier again, nothing would move at all. the only indication that anything was hooked up is I could hear the motors buzz a little when I disconnected everything. any thoughts or ideas on what went wrong and how to fix it? I would include a video of the machine not properly moving in the X or Y, but I didn’t take one before everything stopped working

I assume you checked the wiring to the steppers to make sure they turning in the same direction? Also, perhaps take the chain off the steppers and try motion to see if the steppers turn without moving the gantry. And as always a picture or two sometimes helps.

The vibration but no movement thing makes me think your x and y steppers are moving opposite each other.

Hmm, the z axis is the only one that doesn’t have dual motors. If they are wired wrong (matching colors together) then the steppers at each end will fight each other and not move anywhere.

Otherwise, maybe the driver on the ramps board is screwed up.

The z axis is also the only one without belts. Are the belts on the x and y axis too tight? There shouldn’t be much tension on the belts.

If you unplug the steppers from the ramps board, can you easily move the gantry around? (steppers act as generators when moved manually and can power up or overpower and damage the ramps board or stepper drivers)

Im worried it might be the driver, as the motors dont spin anymore, not since I switched the wires for the X and Y. and yes I can move everything by hand nicely. But I may have overtightened the belts, I was paranoid that I wouldn’t have enough tension on them. I can always loosen them and retighten them though.

I’m not exactly sure how to describe how tight/loose the belts should be besides kinda medium.

Does the z axis still work?

I got the axes moving again. I had just knocked a wire loose without realizing it. but the X and Y are still jerky. I adjusted the tension on the belts which helped a little. heres a link to a video of it operating:

Looks like something is too tight or you have a wire wrong still.

What if you take the belts off the motors and work the different movements to see if the steppers move…