Motors Not Moving after Re-Flash Marlin

Was having issues with the LCD not working.
I only hooked up one X Motor and the LCD

The Motor was working, and tested fine, with Repetier-Host.

but was having issues with the LCD click/flash
Tried turning the cables every which way possible, but could not get a picture on the screen
Could get it to light up properly, but no Text.

Tested the LCD on a RAMPS 1.4 and the LCD does work. So that is not the issue.

Decided to re-flash the Rambo with the Firmware as per

Downloaded the Arduino 1.9Beta

Wiped out all references to previous versions of Arduino IDE to start fresh
Installed Rambo Board 1.0.1
Installed u8glib 1.19.1

Selected Rambo and COM10

Compiled and Uploaded without issue
LCD is not connected

Motors will no longer move.

Checked Fuses

Repetier-Host will connect
But will not jog motors

Checked Y and Z and other motors, no go.

Note, yes, I did power off the board completely before re-wiring.

Note, motors were working prior to Re-Flash

Note, tried a different Stepper Motor that I know is good, and not working.

I sometimes have issues with Arduino’s holding garbage, so I will load the Blink.ino as a sort of reset.
Light on Rambo does blink as it should.

the board seems to work, but no power to the motors


  1. Vref issue?
I am not sure how to test the voltages exactly, coming off the pins for the motors. What voltages I should be seeing?

Also, I do not have a red light on the Rambo indicating incorrect Firmware.

Checking the Cofiguration.h file
Is this correct? #define MOTHERBOARD BOARD_RAMPS_14_EFB


From Repetier

21:03:13.293 : Printer reset detected - initalizing
21:03:13.293 : start
21:03:13.293 : echo:Marlin 1.1.5
21:03:13.293 : echo: Last Updated: 2017-08-28 12:00 | Author: (none, default config)
21:03:13.293 : echo:Compiled: Dec 31 2018
21:03:13.293 : echo: Free Memory: 5508 PlannerBufferBytes: 1232
21:03:13.293 : echo:Hardcoded Default Settings Loaded
21:03:13.293 : echo: G21 ; Units in mm
21:03:13.293 : echo:Filament settings: Disabled
21:03:13.293 : echo: M200 D3.00
21:03:13.293 : echo: M200 D0
21:03:13.309 : echo:Steps per unit:
21:03:13.309 : echo: M92 X80.00 Y80.00 Z4000.00 E500.00
21:03:13.309 : echo:Maximum feedrates (units/s):
21:03:13.309 : echo: M203 X300.00 Y300.00 Z5.00 E25.00
21:03:13.309 : echo:Maximum Acceleration (units/s2):
21:03:13.309 : echo: M201 X3000 Y3000 Z100 E10000
21:03:13.309 : echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
21:03:13.309 : echo: M204 P3000.00 R3000.00 T3000.00
21:03:13.325 : echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
21:03:13.325 : echo: M205 S0.00 T0.00 B20000 X20.00 Y20.00 Z0.40 E5.00
21:03:13.325 : echo:Home offset:
21:03:13.325 : echo: M206 X0.00 Y0.00 Z0.00
21:03:13.325 : echo:PID settings:
21:03:13.325 : echo: M301 P22.20 I1.08 D114.00
21:03:13.497 : N1 M11034
21:03:13.497 : N2 M115
21:03:13.497 : N3 M10536
21:03:13.497 : N4 M114
21:03:13.497 : N5 M111 S698
21:03:13.497 : N6 T0
21:03:13.497 : N7 M2022
21:03:13.497 : N8 M80
21:03:13.590 : FIRMWARE_NAME:Marlin 1.1.5 (Github) SOURCE_CODE_URL: PROTOCOL_VERSION:1.0 MACHINE_TYPE:3D Printer EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
21:03:13.590 : N9 M220 S100104
21:03:13.590 : N10 M221 S100
21:03:13.590 : Cap:EEPROM:0
21:03:13.590 : Cap:AUTOREPORT_TEMP:1
21:03:13.590 : Cap:PROGRESS:0
21:03:13.590 : Cap:PRINT_JOB:1
21:03:13.590 : Cap:AUTOLEVEL:0
21:03:13.590 : Cap:Z_PROBE:0
21:03:13.590 : Cap:LEVELING_DATA:0
21:03:13.590 : Cap:SOFTWARE_POWER:0
21:03:13.590 : Cap:TOGGLE_LIGHTS:0
21:03:13.590 : Cap:CASE_LIGHT_BRIGHTNESS:0
21:03:13.590 : Cap:EMERGENCY_PARSER:0
21:03:13.606 : N11 M111 S687
21:03:13.606 : X:0.00 Y:0.00 Z:0.00 E:0.00 Count X:0 Y:0 Z:0
21:03:13.606 : N12 T0
21:03:13.606 : N13 M155 S1*82
21:03:13.606 : echo:DEBUG:INFO,ERRORS
21:03:13.606 : echo:Active Extruder: 0
21:03:13.606 : echo:DEBUG:INFO,ERRORS
21:03:13.606 : echo:Active Extruder: 0

Probably not your issue, but your version looks a little off. On the github page, just above the file listing, there’s a dropdown to select a version. I’m guessing your using the Rambo with the T8 lead screw, so you should be using the “MPCNC_Rambo_T8_16T_LCD” version of Marlin. Aside from that, some pictures would help.

1 Like

Ok found that version. But not familiar with compiling it. Tried VScode with PlatformIO. I did get it to compile but still not working.

I have a Ramps 1.4 I need to setup. Will try that instead.

so far, not a fan of the Rambo board.

Why not just use Arduino like you did on the first step but with the correct files? Flashing the Rambo is no different than the ramps. I have step by step instructions with pictures on the firmware page.

1 Like

I bet money you will think differently when you go to change a digi pot and don’t need a miniature screw driver and a multi meter.

I had an similar issue and it was caused by the Endstops not right

Holy crap, I learned something today.

So, I did not know you could just grab the git file and load it into Arduino and compile it.
I have a tendency to overthink things when I am not sure what I am doing.

It’s working again.

Also the LCD is working, but had to flip them around.
Red wire towards the middle of the board, away from the Power Plug.
same plugs, just lipped opposite of this…

Motor on X for now is moving via the LCD and Repetier.

For now I am going to leave these as they are. I will have to dig into this a bit more later.
#define DIGIPOT_MOTOR_CURRENT { 120, 120, 120, 120, 120 } // Values 0-255 (RAMBO 135 = ~0.75A, 185 = ~1A)

Thank you for the assistance.
More to come…