Motors not moving

im trying to run a test on the motors and I have it hooked up and repetier is talking with the arduino but its not moving when i try to send a move command. Any suggestions? (I wont be 3d printing with my machine, just need a way to test the motor function)

18:48:54.683 : No start signal detected - forcing start

Version: Repetier 1.6.2

DO you have the resistor connected to t0? windows or mac?

correct, soldered strait to the board

OS: Windows 8.1

DO you get an error in repetier, what temp does the extruder show?

just this one 18:48:54.683 : No start signal detected – forcing start, temp shows zero


If the resistor is on the correct pins, then it is not really connected, repetier should be showing an error. You could be having a driver or com port issue. Are you using the arduino drivers that came with the arduino software?

yes, arduino version is 1.65

In order to get the windows 8.1 to recognize it, I have to plug in the USB to Arduino, then to the pc, then plug in 4 port green power cable, and windows loads the ardunino driver


It should not need the power to be recognized. Do you have a different usb cable to try?

ahh, i thought it needed the other power supply as well. So the motors can run without the green power supply (12v)?

You didn’t buy it for me, did you flash my firmware on it? If you power the Arduino board and the ramps board at the same time you might have fried your Arduino Mega

correct, should I flash it again? B16_32-LCD-112515 – Use this if you don’t have the full Graphic LCD screen.

Any updates on this, you moving yet?

no, nothing. Still not working, even after flashing it again.

So did you ever plug in the ramps shield power supply (green plug) and the arduino power (barrel plug) at the same time? This would fry your voltage regulator. Do you have an lcd screen to run it from? When you flashed it it flashed successfully?

Because it is not from me we have to step back and check all avenues.

I plugged in the Ramps shield power supply and Arduino USB only per

I am not using an LCD screen

The Arduino IDE said: Done uploading after removing and re-adding B16_32-LCD-112515…

If you have an LCD that would be an easy way to take pc drivers out of the equation.

Can you try in on another computer? Just had a user today by email with very similar problems, tried a few different drivers no success, plugged it into a different computer, no issues fired right up. The fact that your is on com 6 says you have a very good chance of at least 3 other devices/drivers screwing with it somehow.

sure, ill try it on the computer that has the 3d printer on it and let you know if that works

It worked… sort of. The software is showing in repetier but the motors only work once. I can plug in a different motor to all 3 different ports and they all do the same thing, work once then dont work at all anymore.

If I plug one in and click home or run multiple commands to that axis it will work just fine then if you unplug it and plug it back in, it no longer works.

ok looks like its fixed, the Ramps board needs a switch added to it, anytime it gets shut off from repetier or the motors get switched, the entire board needs to be unplugged and plugged back in.

I will need to create a new thread for trying to figure out which type of fan to add to the RAMPS board.

If you unplug a stepper while powered up you will blow your driver, if you catch one energized or moving. You should be completely powering down and unplugging power and USB before unplugging a stepper.

Sounds like your board is fine.

Thingiverse is full of fan options for a ramps stack, user preference.