Motors not moving

Hey everyone,

I just finished my first MPCNC build. I put all the parts together, flashed the arduino, plugged the motors into the ramps shield. I downloaded and installed Repetier-Host and was able to successfully connect to the board. I was unable to move any of the motors in any direction. I am not sure where to go from here to resolve the issue.

I did not mess with any of the potentiometers yet as I was hoping at least one of them would be good to go. Good enough to at least move a motor or give a buzzing sound. But nothing.

Any suggestions are greatly appreciated.


If they’re buzzing but not moving, check the wire pairs. Sometimes they’re not standard.

I didnt hear a buzzing sound either.

What do you mean by “wire pairs”?

I bought the wires from vicious1 store for stepper motor to ramps board.

what drivers and what steppers? the drv8825 drivers come at almost 3 times the recommended voltage, careful.

We need a lot more details to be able to help you.

using the resistor?


Im using the drv8825 I purchased from your store. I also put the resistor on “T0”.

Steppers are NEMA17. Should be the same model number that is available on the store.

I will post photos when I am back home.

mac or pc

PC running windows 10. I also tried to move the stepper motors from the screen which is attached to the ramps board but still no luck.

I guess a picture is needed then.

My work space is in shambles at the moment o_o

Let me know I should take any other photos.

You need to plug it in.

Usb doesn’t power the steppers.

It just wasnt plugged in there in the photo. When I successfully connect to Repetier and still unable to move the steppers I have both power cable and usb plugged in.

correct polarity?

does repetier give you any errors? does it say commands waiting? what buadrate?

repetier does not give any errors. It says command waiting for a few seconds then goes away. Baudrate is 250000 (default)

Ive also triple checked my settings against yours in the assembly instructions.

If you unplug the usb and just use the power cord and the screen you get nothing as well? Does the temp show up?

Make sure the 2 mosfets are not touching, they are close but I can;t tell.

Just tried without usb and screen only. It didn’t work. The temperature on the screen says 25 degrees.

I separated the mosfets to make sure they arent touching each other.

I don’t hear any buzzing or sounds from the steppers. I can also turn the stepper by hand even when everything is plugged in and on.

I am having the same exact problem and I have the same exact situation,
purchased 3 days ago the rams lcd and cables here not nema 17 and 12V power supply.
But having exactly the same trouble.
Help please

hmmmmm, I’m stumped. Until we get it going make sure you are only using 1 stepper plugged in directly. x y and z to eliminate wiring issues.

But first lets try something. Make sure the power is disconnected. unplug a stepper and short the outer wires of the stepper plug to each other with anything, small piece of wire or paper clip. the stepper should be noticeably harder to turn.

If you were to number the wires in the stepper plug they would be 1234, 1&2 should be a pair and make it hard to turn, same with 3&4.

Short the wires of the stepper plug when it has no power going to it?
I’m sorry but i’m confused on what you mean.

Something like this?

yes, exactly