Motors not turning

I bought the Ramps Board ,motors and all the wiring ext, I can not get the motors to move at all. Repetier in manual mode shows up on LCD screen when i access it, but the xyz axis on lcd screen blink between the Letters XYZ and a ? mark.
I get a yellow light blink on ramps board when i reset it but that is it. read on the forum ? and answers i can find on subject I have a Power supply wired to the green connector like it is supposed to be ,tried different usb cables.i have hooked up just one motor for each axis on ramps board, still no movement on motors, but shows movement on lcd screen. Thanks for any help you can give or direct me to

The question marks are normal.

You bought it all from the site? There are a few other questions in the sticky that really help out as well.

Lets see some pictures of you board wired up.

Can you move the steppers from the screen?

Yes i bought everything from your web site.
no it will not move from the lcd screen or the computer screen


Your power wires are in the wrong spot. Move them over to the other pair.

push the button (knob in), a menu pops up, select prepare, push the button, select move axis, push the button.
no movement at all

That did it !, I saw this pic of the wire connector and assumed with out the jumper it was where it went
Thanks guys!



If you’re going to use a 3d print head on the cnc, you’ll need those jumpers. Doesn’t really matter which pair is connected to the power adapter.

ok I got the Z axis and y Axis motors running good .the 2 motors on the x axis hum and tick .
i have moved the driver chipd around i have a Extruder drive i swapped out. and the motors still are doing it iswapped xand y on the ramps board and the x axis is still doing it.
im thinking some thing on the ramps bored is doing it?
my power supply (20wwatt) light starts flashing when it happens .i have to get the reset button on ramps to get it to stop.
Any Ideas?

Double check your connections. If that doesn’t do it lets see some pictures of your wires and connections.

I have disconnected the motors from the double wire harness . I have installed just one motor to the ramps board and it still did it . I then installed the opposite end motor and still does same thing . I have moved the drivers around , but the problem stays on the x axis

ok Guys i got it ! bad 12v power supply, brand new too!
Switched out to a 24 Volt switching Power supply and problems disapeared !.
Will i damage any thing by useing this type of power supply?


24V will most likely fry the voltage regulator on the arduino

Yes will cause damage, you have to modify the shield first and use a second power supply. Lots of info on this out here, this used to be a common thing.

Thank you, I ordered a new 12 power supply instead ! Much easier to deal with .
Thanks to who all replied to my ?
Great group of people