Movement failure only when printing.


I’ve been milling with my mpcnc for several months now without any issues. It’s been running the entire time with an extruder and hotend attached to it. But hadn’t gotten around to printing with it since I have two other custom built printers.

For milling I run it either through repetier-server or octoprint.

Now I’m trying to print with it. Yet no matter how I generate the gcode, either with the settings recommended for slic3r or cura or repetier-host (which all things being equal should not make a difference). The machine engages and operates like it’s having a seizure.

The behaviour is such that the machine is jumping around like its getting excessive acceleration pulses. Has anyone seen this behaviour before? Because I haven’t and regularly build 3d printers using ramps and marlin as well as mills usually running linuxcnc or grbl.

If I use gcode generated for milling using either estlcam or vcarve pro the machine moves perfectly.

My ramps is running RC7 currently. It is extremely rigid (its built inside a custom enclosure with the corners milled into the enclosure). I use a dewalt dw660 and its constructed largely with 525 components with the exception of the custom enclosure.

Any ideas would be appreciated.

lets see your gcode. zip it and upload it here.

Will do,

It will have to wait until I get back home, I’m away for the weekend. And only havw my crappy tablet with me.

Thanks for the quick reply.


AHA, I’m going to test this as soon as I can but I think it’s an issue of draw. The power supply I currently have attached to the thing only provides enough current to drive the axis steppers! As soon as I add another stepper and a hot-end it creates havoc. I should have realized this from the get go.

It’s a wee little 8 amp supply, which surprisingly drives the parallel drives and z axis quite nicely. But I’ve been running it like that so long that it had completely slipped my mind to swap it out.


It must be not actually 8A, I run on 5A just fine even with a hot end.

You’re likely right, its a pretty crappy psu which is why it happened to be unused at the time of the build. I’ll let you know what the larger psu does tomorrow when i get a second to test it.

thanks again.

I confirmed my suspicion it was a bad power supply. The machine runs smooth as butter while printing now.