MP3DP "Repeat" Build

Ok.
What i’m experiencing must be firmware related, I’m sure I it is not a mechanical esue. I can do G28 and bed goes down, sense all 3 “motors/endstop” then I do a G29 and the BLThouch “senses” the first 4 probes of a 5x5 mash… and it stop…
If I isue a G34, after the initial Z moviment bet moves up, BLTouch deploys and after sense the bed I get an error… Probing faled like the picture cople post up…
I’m going to upload the original firmware without any changes and trigger the BLTouch manually
somehere around 200mm just to see if I can finish at least one round of the G34…

This is my start gcode,

G28

G1 Z10 F6000

G34

G29

Are you using my precompiled firmware, from the marlin builder github just editing the build size?

1 Like

Sorry on the late response,
Yes your firmware only changing the bed and Z high . Last night I downloaded another copy of the firmware upload the firmware “ as is” and got the same error. Right now I don’t know what the problem is… still I think it’s something that I’m missing.

Yeah this is tough. I am very new to this printer, the bl touch, and any form of leveling. I have no idea what could cause this, but I am willing to poke and prod at the printers I have to help.

1 Like

This sure looks like the output from the bl touch isn’t going to the right place as the input to the probing sequence.

That sounds like the only thing you should need to check. When I first had a bl touch (well, it was a “3D touch” knock off version). I had a heck of a time figuring out what it was doing. I ended up attaching a scope to see it trigger and I hammered M119.

Just to be clear, I would expect the “zmin_probe” to be triggered when you test M119.

The firmware is definitely new. There could be bugs we are finding. Or maybe we configured it in a way you didn’t expect. In my experience, if M119 is right, and the motors are moving the right direction and speed, then the homing and probing just works.

1 Like

Does the BLtouch miss the corner of the bed?

Thinking back, I remembered that I had to reset the endstop offsets. I had to increase the X offset by 10, and the Y offset by 56 (Since your Y rails are 50mm shorter than mine, I would think that 6mm would be enough) Just resetting the bed size and Z height isn’t enough, you have to also set the endstop offsets.

My suggestion:

G28
G0 Z5 F3000
G0 X0 Y0

Now, look at where the print head is. You want it to be right above the front left corner of the print bed

If it isn’t, use the jog controls to move it there, and then see what the LCD says. Use those numbers to adjust the endstop position in Marlin’s configuration.h

Edit: It also occurs to me that you remoxed the fan shroud piece. Did you change the probe offset from the nozzle in anything other than Z for the Volcano heat block?

2 Likes

Didn’t have time to work at the printer this weekend, family affairs….I will have a little time tonight.

Yes you are right, Could definitely be a bug.

No it doesn’t, it is pretty much right at the edge when probing. I will add a picture when I get home.

I will do that, if I’m not mistaken, my nozzle is about 3 mm in on X and Y axis.

I didn’t need to change the probe offset as I just added the difference in height from the heating block to the space between the hemera mount to the shroud, I believe it was 1 mm…I will add a picture too

What version of the bltouch is it, if it happens to be an older one than a 3.1 I believe the firmware setting are differnt?

The offset needs to be between 2.3 and 4.3mm, just to be certain.

You have us all curious now…if you were local we would all be at your place burning the midnight oil for sure!!!

I know right!!! That would be so cool…

Here it is… stow and deployed
Screenshot 2021-11-14 213942

The BLTouch is brand new and it is a 3.1

I didn’t change the offset. I left as is. 2.7mm

Here is the Picture:
BLTouch X - 14mm. Y- 16mm

Nozzel 3mm on X and Y

And here is the fan shroud, the distance from it to the Hemera Mount was 1mm and I changed to 12mm

I’m going to start from scrash. I also have another board to test if needed

Accuracy test for the bltouch?

G28

M48 V4

Here it is…

That looks pretty good.

It worked?!

Yes it did, but still, no joy trying to Auto Z-align or even Bed Level.

Problem solved!!!

Replace the board and everything is working!
I can’t beliave it, that board was brand new, it was just seating in the shelf unopened for about 3 months.


1 Like

Oh boy. That is strange.

Right, the board has no noticeable damage, nothing burnt that I can see…

1 Like

An m48 worked, but neither M29 or 34 did. I can’t believe that is somehow board related, what the heck?!

1 Like

I decided to replace the board after reading on Reprap forum where a guys had the same problem with the Octopus Board

If the firmware can see TRIGGERED, then I have no idea how this could be hardware related. That’s what bugs me.

1 Like