MPCNC cutting issues

Dear MPCNC’ers,

I have been working on my MPCNC for a while now and keep running into the same problem over and over.

Since I haven’t found any topic describing the exact same problem, I have decided to start one.

The problem i’m having is the machine SEEMS to keep ‘hanging’/gets ‘stuck’ on random point, causing the whole print to get off course.

I’ve tried A LOT to come up with a solution on my own. Since i can’t seem to solve it on my own i’m hoping someone could point me in the right direction (any help is greatly appreciated).

My attempts so far:

  • reassebled middle assembly;
  • reflashed firmware;
  • rewired everything;
  • upgraded to the best quality rods I could find;
  • added corner supports;
  • upgraded routers (Chinese to Makita);
  • tried different belt tensions;
  • tried different xy speedsettings in Estlcam and feedrates (tried 1200, 1600 and 2400);
  • tried various bits (currently using an 1/8 (3mm) 2 flute end mill
Possible problems which I believe are definitely not the cause:
  • Router(s)
  • Rods
  • gcode file (one cut turned out perferct)
Since pictures probably are a lot more explanatory, i have added these. Furthermore i have uploaded a video on YouTube (note that this was made before I swapped routers and before i rebuilt the middle assebly). In the video you can hear the motors struggling at around 01:00, around 01:30 things go really wrong.

Video link:


These things should all be included in your post. It makes it much faster to diagnose problems.

  1. Did you buy everything from here? - No.
    a)If you didn’t or changed some things please don’t leave out any details and include what firmware you flashed. - Used firmware from Vicious website.

  2. Are you using end stops? - No.

  3. Mac or PC? - PC.

  4. Include a picture so obvious errors might be spotted. - Added.

Looks like you are using the ESTLCAM firmware, please re-flash back to my marlin one and see if it goes away. I think your settings are incorrect in the estlcam and you are overloading the processor.


Extra pictures.

Also noteworthly: there is zero play in the frame,

z-assembly is nice and rigid (runs smooth, and has no play),

relative simple cuts seem to go ok (mostly),

I’m cutting at a depth of 2mm per layer (also tried 1mm),

It is mostly the second or later layer where things go noticably wrong/off (first layer is mostly ok).


In your “estlcam settings 2” picture you are missing the most important number, the z max feedrate. That is overloading the processor and freezing it.

Thanks for your quick responce. Will give that a try and let you know.

For completeness’ sake, could you point me to the right link containing the firmware?

First this,

Then triple check this, step by step and you can run my gcode at the end to test.


Thanks. Will flash that firmware tomorrow.

I did the ‘crown’ test drawing after completion of my build and that turned out perfect.

Is the recommended z max feedrate of ‘480’ also the recommended value when using a T8 lead screw (instead of a threaded rod), or should a different value be used in Estlcam?

Did you adjust the stepper motor drivers?

You can go up to 1800 with a t8, but should stay under that.