My cnc wont respond to move command from the lcd

Using the skr pro and lcd. Did a couple drawings perfectly after finishing my build and shut it down for the day. Came back next day and now none of the motors respond to touch screen controls. I went into the screens settings and reset the settings which got things moving but only 1 motor on each axis would move. Reflashed both frimwares and its not moving again. Havent tried pc control yet as i dont have a long enough cord.

@Souljasam I had a similar issue in TFT mode. I was able to get it working again by doing the following:

  1. In TFT mode, change to Marlin mode (hold knob down for 3 seconds and select the Marlin icon).
  2. Power cycle board. It should boot up in Marlin mode.
  3. Change back to TFT mode. Motors worked again after that.

This also solved the problem that I was having that the LCD SD card was not shown as an option when I selected the cutting icon. Hopefully that helps.

I have already done that a few times and it hasn’t fixed it. Mine has been reading the sd just fine but when i go to select something to cut nothing moves.

There may be something to this, but it honestly feels like superstition (or over matching a pattern).

The motors moving or not has zero to do with the screen. If the screen can’t move the motors, it is because it is not connected to the control board. The screen has no responsibility for moving the motors.

The best indication is the “no printer attached” message. That should go away in a little while (<30s) but sometimes does take a little time to connect. The tft firmware is not perfect. But it should work ok. The marlin mode is very robust and should be your choice if you are just trying to get cutting.

Marlin mode wont boot. Im gonna try connecting my laptop today since i found a longer usb cable. But still, i want to remedy the tft issue. I found stuff about changung the baud rate which i will try today.

True, it could be coincidental. I did try to power cycle it a few times when in touch mode without success. It only worked after I switched modes.

Before I switched modes it showed the “no printer attached” message and the onboard SD card option was missing even though I received the “SD Card inserted” message when I inserted the card. Maybe I just needed to wait longer but I had been playing with it for a couple minutes so I would think that would have been more that enough time to connect/initialize. I’ll try to dive deeper if it happens again.

Yeah. Like I said, that firmware needs a bit more work. We disabled the M221 message, because it was causing errors with firmware without extruders. It makes me wonder if there needs to be some replacement to use as a heartbeat message between the boards. IDK.

Well i changed the baud rate and it connected between a few resets and then suddenly wasnt connecting anymore again. I had it moving around and marlin mode working fine. Now marlin wont load again and nothing moves. Double checked all my connections and its not that. The lcd just doesnt want to communicate. I havent tried from my pc yet but im pretty sure that will work but i really wanted the lcd to work.

The LCD in marlin mode should be rock solid. If it isn’t working in that mode, either something is wrong with the skr pro, or the cables aren’t right (or maybe something is wrong with the LCD). Connecting to a computer would tell you if the board was working or not.

Yeah. I dont think anything is physically wrong because it has worked. And if i swap how the cables are wired it doesnt even show the simulation message and black screen like it is now. It will just be a black screen. I just dont get how or why it worked and then suddenly isnt working again.

Well, software doesn’t change like that. But you can try flashing it again.

Having this issue again. Flashed the firmware again and it fixed it until i powered it down, left it for a few days and came back to it. Now it says printer not connected again and it will only move 1 motor on each axis again instead of both of them when controlled via repetier host. All the connections are good.

Does it work in Marlin Mode? Can you confirm the software is 509 from the boot screen in Marlin mode, or from RH with M115?

Marlin mode doesnt work when the lcd doesnt connect and im having the motor issues, but works fine when the lcs connects fine and the motors work like normal. Ill check that when i play with it tomorrow