My Crown...for diagnosis

Okay, here it is. I didn’t bother sharing any of the tests form the past weekend since it was someone else’s computer and I’d need to reset everything once I figured out my PC solution. So here it is. Run off SD card from LCD screen. It DID draw “right side up to me” so flipping the X/Y plugs seemed to fix that. I’ll try some lettering next so I know if I’m getting a mirror print or not.

A few observations.

  1. It seems to be "outlining" the start of each new tool path (you can see the heavied up sections) painfully slowly and then once it's finished the outline paths it kicks up the speed and draws what looks to be right betweeen the two start lines and then completes the rest of that path in a single stroke. I don' tthink our tests last weekend did this so there must be a setting somewhere I've missed?
  2. I need to have the pen sitting right on the paper (bleed dot at the "origin point") to get it to step down enough to actually draw. Is this the 1mm tool depth I set when saving the gcode? I could be just the 1/4mm off when setting the origin.
  3. I see some slop in the belt/ziptie system. Can I tighten them up a bit to try to eliminate that slop on direction changes?
One other general question: When power cycling to set 0,0,0 do I need to wait 2,5,10 secs before powering back up or is any power cut fine? Just curious.

Happy to report that I’m not printing mirror images. Disregard the stray line there - started wrong file and aborted it. Print went the same as crown test. Outlining slowly and then drawing right down the middle in a more speedy manner.

Maybe some extremely low acceleration settings?

Can you tell us more about what board you’re using, what firmware, where did you get them, what changes did you make, all that stuff?

It’s all from the shop here. Mini Rambo, steppers etc. Even the preprinted pieces. The only changes I made were the initial settings setups in Estlcam when I installed and launched it - all the ones outlined in the Estlcam Basics walkthrough

All other settings were left at whatever defaults they open in. I assume the firmware is the most recent.

I’ll find a pencil or ball point (something that won’t bleed) and try again so I can see if it is indeed outlining the start of the paths or just drawing the path starts three times before kicking off on it’s merry way. Perhaps I can grab a video too…

Okay. I used a freshly sharpened pencil and it appears it’s drawing the first bits of each path three times WHILE lowering the Z-axis gradually from 0 to -1. Once the z-axis hits -1 it cranks up the speed and churns out the entire path.

Snugged up the belts a bit while it was running too in order to take out some of the slop. I was seeing flex in the adjuster zip ties as it jogged back and forth so I snugged it until there was no more flex.

If you zip and upload your gcode we can look through it for some typical issues.

Can do! These went form the PC to the Mac, zipped on the Mac and uploaded here so don’t be surprised if the gcode files are scrambled. In fact, DO be surprised if they aren’t! Ha! (27.8 KB)

Yeah that is messed up, where your plot is dark it has multiple passes. I think you might have ramping turned on. Also you feedrate is 3, and your plunge is 8. Might want to reverse those.

I would say try again, if it still has issues get a screen shot of the estlcam screen with the tool window with the crown as you have it.

I just found the gcode tab in Repetier…am I over simplifying it thinking it’s point A to point B to point C etc at whatever given depth (Z) and speed (F)?

F480/F180/F2100…I gather that’s the feed rate…or the speed the tool moves (one in the same)? I see the repeating segments of code too - but with the diff Z depths. And the speed up - looks like it goes up to 900? I’m going to redownload your gcode for the crown and compare. I’ll run it too.

Wait…What is/are the I and J? Is that the feed and plunge? Where in Estlcam is that parameter set?

I redid the Estlcam stuff and grabbed screen shots. I assume we don’t need any settings changed in the CNC Controller Setup screens? I already know what’s going to happen in the shop when I run your 12mm/s file but I’ll run it anyway. My CAM preview (is that the right terminology) in Estlcam after exporting the file…the preview of the cutting paths, it still made two starter passes before carrying on for a third pass over that little section and then did the whole thing.


EDIT: Yours ran flawlessly. And the tighter belts had all finishes end right where they started. Sweet!

Don’t worry about I and J.

What are you setting your toolpath depth to? Are you just setting it when it asks before generating code?

In Estlcam when saving the file off I set the toolpath depth to 1mm. I see however in the gcode (and while watching the LCD screen) that the z-axis drops slowly - presumably during the first two passes on each path. I saw in the Basics walktrhough that the depth can be set at each path when selecting them so I tried that way as well. It did not prompt me when saving for the toolpath depth but in the preview it did still take two passes over the first bit of each path before the full draw, There was no speed difference in the preview but none of them have shown the slow first passes, just regular speed repeated passes.

Ryan mentioned something about having Ramps turned on - I can’t seem to find that settting in Estlcam.

Those settings are part of the end mill settings.

a(Z+) change that to 90. You should be fine after that.

Beauty! Thanks for spotting that. One day I’ll know what each of those settings mean/do.


So just one little spot on the new crown that I think can be looked at. The circle under the center cross. Didn’t quite match up. Any thoughts? I wonder if I could do with a little bit more belt tension?[attachment file=69010]

If you hover your mouse over then boxes they give pretty solid explanations.

The circle could be many things. Most likely is the pen and how it is set up. A picture of your build as it is with a pen is worth a thousand words. Try a ball point as well to get a more clear picture of how it is doing.

I could see the culprit being the pen/mount actually. I didn’t really crank down on those zip ties and know I could get it more solidly mounted. I watched all the other joins very carefully and they were all spot on but the circle is a bit different torsionally than the rest of the drawing. Pics nonetheless…if this works. Using the iPad tonight.

Thay looks okay, just make sure to use as little preasure as possible.