My MPCNC is doing strange things

I built my mpcnc rougly 1 year ago. I am very happy with the machine, and I would like to thank for that wonderful project.

I have been using it with laser and it works very good.

However when I started to use the spindle, the machine is making some strange things.

For instance.

1.It is doing 4th pass on the material, and suddenly it is going to the first pass (Z level 0)
2. It is cutting the object and suddenly it is going across the object destroing the object and the tool.

I ran those gcodes once again with spindle turned off and it is OK.

I am buffled what is happening here. It seems like there is some interference from the spindle.

Has anyone of you expierienced such behaviour?

  1. Did you buy everything from here?
    a) Nothing was bought from here.

b)What board do you have?
Makerbase 1.3

c)What firmware is on it or which did you buy it with?
Marlin

  1. Are you using end stops?

NO

  1. Mac or PC (windows xp, 7, 8, 10?), linux?
    PC WIn 10

  2. Include a picture so obvious errors might be spotted.
    NO errors

Might be electrical interference from the spindle.

Or your rapids are not set correctly. Lets see some Gcode.

Yeah, both good suggestions. Try plugging the spindle in to a different circuit than the rest of the electronics. If that makes no difference you’ll have to look at the Z rapids, if they’re too fast (too fast depends on your setup, all-thread or lead screw) it can get really, really weird.

[attachment file=“codes.rar”]

Hello,

OK, thanks for suggestions, however I am just thinking what Z movements have to do with the CNC going completely off the path.

For instance it is cutting gear and it suddenly goes off the path and smashes into the object.

I am adding the attachement, but I can see it in my post.

You have to zip the gcode.

What you are describing happens as a result of either of our suggestions above.

You can zip and attach your gcode and that can be checked very easily. As for interference is is more often the case and only you can check that by running the same code with the spindle turned off in the air. No errors you have interference.

 

What you are describing is an issue we all understand. Start with the two suggestions above.

yeah, I know I need to zip it, actually I rared it and it doesn’t show up on my post.

 

 

[attachment file=“codes.rar”]
[attachment file=60373]

Files.zip (36 KB)

Your gcode is no good. Look through the estlcam basics, you are missing your rapids.

https://www.v1engineering.com/estlcam-basics/

1 Like

Actually I was using the machine for almost a year without rapids :slight_smile:

Thanks for pointing it out.

We all did, it took us collectively more than a year (2015 is when that linked page was written) to find the issue and solve it. It only shows up when you overflow the buffer too much.

 

As I said it was a very common issue. Now that you use all the correct settings you should have a much smoother experience.

We have since collectively written many post processors to handle the issue, in programs other than estlcam as well.

You mentioned the buffer issue. Yeah, it is now quite clear to me why it always happened when I was using trochoidal milling.

Everything is so easy only after it is solved.

Now the machine is really running a lot better. Thanks to you and all others for the help.

1 Like