New build end stop and "NPA" issues

Long time reader first time poster. First off I want to say what a great community of helpful people. I haven’t had to post yet as most of my questions were asked with simple searches in the forums. So about a month ago I started to print the parts. Got it all assembled and working. I just have a couple issues. I have researched and can not for the life of me find a solution. I even bought another SKR board thinking I fried the first one but the new one functions the same.

Board: SKR 1.4 Turbo
Drivers: TMC2209
TFT: BTT 3.5 V3
Firmware: Expert Noob 1.4 Dual
SD cards: both generic and Sand disk Quality tried
Limit Switches: from V1 Eng

All connections were soldered using shielded 18awg 4 strand wire to JST HX connectors. Flashed firmware to original board using VSCode and everything worked fine in touch screen mode when not connected to anything on the bench. Now that firmware was flashed and tft was flashed and working I put back in box and finalized the build. When I printed out the TFT holder I decided to use I put the screen in and tried it out. Well being a NOOB and becuase the screen was oriented differently in case I screwed up and plugged the 5 pin JST into the other 5 pin port on the TFT by mistake. When the screen wouldn’t power up I realized it, corrected it and then couldn’t get the “NO PRINTER ATTACHED” message to go away in touch mode. Also all of the parameters are zero in every menu. When I send M commands through the terminal no response. But like I said switch over to Marlin mode and it works fine.
I plugged it into pronterface and it connects no problem. I run M commands and get responses.
I uploaded the crown gcode I created in Estlcam and it printed no problem to scale. Would love to use this with the touch screen though.
I also connected my limit switches to both the NO and NC positions for my dual endstops and both ways I get all reading TRIGGERED from M119.

4 Likes

Marlin Mode and TFT mode use different cables. Marlin Mode uses the two gray cables I see in your pictures. TFT mode use a thinner, black ribbon cable that I don’t see in your pictures.

2 Likes

That’s a pretty machine and table

2 Likes

I think it is that rainbow one, with red, white, black, blue, and green and the JST connectors.

Nothing on the touch screen will work if it has the “no printer attached” printed. The first thing to try is to make sure the baud rate in the screen settings is set to 250k, unless your expert noobs firmware is set to 115.2k. (That’s not my firmware, so I don’t know what it is set to).

Then double check that rainbow cable. You don’t need reset, and I am guessing the 5V and ground are right. So the only way it could be screwed up is if you have tx and rx backward. rx on the screen needs to go to tx on the board, and vice-versa.

Great post, with excellent pictures and details. It really puts me in the corner for what I can ask for :).

1 Like

Yeah I read here that little black cable is the source of issues so I eliminated it and replaced it with that multi colored cable with jst on both ends. Thanks though.

Thanks brother, I checked out your build as well looks good!

1 Like

So I will double check the RX/TX thing this morning. Man I hope thats the issue. I tried it with the black cable that comes with the screen and no luck. I will cheeck the firmware config file and make sure the end stops are correct. Can you verify for me that the limit switches should be wired NO and the board connections for each switch are ground and signal only?

Thanks for all the help!

The v1 firmware should be NC to ground and signal. But that isn’t my firmware, so I don’t know what they configured it for.

Did you change the baud rate on the screen settings to 250k?

THAT WAS IT I had the damn plug plugged into the wrong port again. :confused:Out of dumb luck the grnd and 5v were in the right spot to power the screen but not talking to the SKR. I swapped the green an blue wires on that multi colored cable I built and walla it works like it should! Thanks a million Jeffeb3! :nerd_face:
Now as far as the code goes, I am using this firmware cuase I didnt see a 1.4 turbo firmware on the V1 website. Can I use the 1.3 SKR firware and just change the the processor and description in the config file?

2 Likes

Very nice build love the table.

There is a turbo, but not 2209 and a skr pro with 2209. I have been meaning to try to cook up a turbo with 2209 (and I think there is a version in a pull request) but I haven’t had the time.

Glad you got the screen working.

OK so I downloaded this version - Marlin_V1CNC_SkrTurbo_DualLR_8825_2.0.7.2_510-src- Edited for my bed size and drivers. I also desoldered all the DIAG pins from the TMC2209 drivers and now all my endstop switches are recognized. So self leveling and homing on XY work flawless, soft stop double bump, cool!
Now the Z axis and the probe to finalize this!
So when i send M119 I dont see z_min on the screen only z_probe and z2_max. The endstop switch on the control board side is coming up as z_probe I have it plugged into thye z stop location and the z2_max plugged into the E1 location on the board.
So from what I can demise I need to define the location of the z_min as it is now its defined for the z_probe. Then I need to define another UART to accept the touchplate. I was planning on using the PROBE location on the board and following what some others here have done.

Any help is appreciated! Going to make some test cuts today on some 1/2" foam.

No, I think it is already right. If it thinks it is Z probe, then try a G38.2 Z and see if it stops when you trigger the plate.

Since Z hones up, it won’t have a zmin anymore.

So when I home Z I depress the endstop switch and the Z+ movement continues on both sides. When I check the endstop status with M119 I get open and triggered when triggered. So the switches are working and the software is seeing them functioning.
I have my touch plate plugged into the GND/P0.10 pin. The G38.2 Z command gets a recv ok but no movement on the Z axis?

The home uses zmax and z2max to stop. Because it is homing up.

What if you try G38.2 Z0?

So G38.2 Z0 worked. I reset all my mechanical end stop settings to false except for: Z_MIN_PROBE_ENDSTOP_INVERTING make that one true.
Then I activated the line for: #define Z_MIN_PROBE_PIN P0_10 and plugged the touch plate into the probe socket on the SKR 1.4 Turbo.
I still have z_min endstop showing up when I run M119.
Can I just throw a couple forward slashes in front of that line in the configuration.h file to deactivate it?
But it all works it homes X & levels and homes Y with double bumps. It homes/levels Z in the positive direction but no double bump it just stops.
When I run G38.2 Z0 the Z axis moves down and stops when I touch the clip to the plate.

Yeah Buddy! I now have a completely functioning 49" X 97" LR2 that self levels/homes and works with a touch plate. Time to start generating some Gcode.

I can share the firmware file if anyone wants it. I learned a lot with the trial and error method and the help found here - Thanks a million !

1 Like

I’m a little confused, because I thought any of the DualLR firmware would do this same thing. I haven’t put it on a machine, but the testing I did on my desk made it look like it would work. And I based the config off of some users here that had dual endstop Z working on their low riders.

Jeffeb3 - I know that now. For me the confusing part was the SKR 1.4 Turbo & TMC2209’s was not a preset recipe for the LR. So I went looking elsewhere and from trial and error learned that. Thanks again for helping a NOOB find his way.

1 Like

do you have a copy of your firmware i would like to look at it

Its the standard DualLR firmware I just made changes per the size of the table I was using and modified per my end stop config.