New fusion 360 update breaking post processor

With the new fusion 360 update I now get the error that the marlin post (https://github.com/guffy1234/mpcnc_posts_processor) is a “invalid post processor” , I worked just fine and nothing changed other then the fusion 360 update any ideas?

machine: lowrider 2 w/rambo
software: fusion 360 hobbyist 2.0.11415
os: windows 10

Sorry if this seems like a stupid question still new to this.

I just create a 100x100 square and was able to generate a tool path using guffy and flyfisher604 Post processor. No problem here… My LR also run on a Rambo and I use the same fusion as you. the only difference is that I’m on a Mac. Not sure when the update was send out and if even hit my F360 yet.


This is what the updated ui looks like for me. Edit I am on version 2.0.11415

Ok I found the fix for anyone on 2.0.11415 you have to redo the machine setup
move the post you want (and the JavaScript file) to \Users\YourUserName\AppData\Local\Autodesk\Autodesk Fusion 360\CAM\cache\posts
image


You do this by clicking the three dots next to the machine this will open up machine library click on local and then the plus button that is above where all the machines would normally be.
Then go to post processing select the post processor you want
image
I hope this helps anyone who ran into the same problem I did
Edit: you might have to make the files read only to stop them getting randomly deleted (not sure).

2 Likes

Glad I ran across this thread, and thanks for posting the solution @cassuttaja. My pc just took a dump on me, and I regret to say I had a very poor backup plan when it came to f360, cura, light burn etc. I will have to re-earn the months of tuning on my printer lol, but at least with this f360 won’t be as frustrating to setup again.

1 Like