New machine that is not communicating

I just purchased second hand a low rider with a mini rambo 1.3b motherboard. Came with no computer so I have been trying to download everything from scratc . I somehow and someway messed up the preloaded firmware on the board and it now has a red light lit up. When I first got it I could manually control the router from the small LCD screen wired into the board but now I cannot do anything with it.

Typically if the red light is on when powered up the wrong firmware is on it.

What an interesting machine. That is not a stock LR. When you get it working, I’d love to see more pics of it.

More info on flashing is here:

Okay so far so good. I have the machine back to where I can manually move it. I am trying to use repetier-host to test it but it’s not working. I have the com port recognizing the board with the latest driver installed (on COM3) and I selected COM3 in the printer setting, but I get “Access to the port ‘COM3’ is denied”

Mac or PC, baud rate?

1 Like

Okay I am almost there. I figured it out. I am using a PC and the baud rate is 250000. The last thing I need is to figure out a free g code sender that will work. I tried using UGS but it will not connect. I tried using Repetier-Host and can manually move it but can’t figure out how to get the g code to work properly. My endstops are not set in Andruino and I need to figure that out as well. Lastly, I paid for and I am trying to use Mach3, but apparently I can’t talk to the Rambo mini without some type of convertor. The guy that I bought it from was using some type of free gcode sender (besides UGS) but I can’t remember the name of it nor find it that I know will work.

Did you see this page on repetier host?

You should be able to just load it and press print.

Marlin is 3D printing firmware, but it works best for our uses as a cnc machine.

The other problem might be that the gcode you’re making isn’t right for Marlin. You usually need to use a Marlin post processor. More info here:

There is a test gcode file to print “The Crown” here:

Mach3 won’t work with Marlin. It wants to control straight from the PC. I don’t knoe much about it, but you’d at least need some other software on the rambo for that to work.

1 Like

Okay so the crown was definitely not a crown it was more like three lines or so. How do I calibrate this thing?

Sorry, I am so new to this. I am surprised I even got it talking to the computer honestly.

Do you have your coordinates right? The crown is meant for:

X Positive to the right
Y Positive away from you
Z Positive up

When you’re from the perspective of that picture.

When you run the crown, you need to start at the lower left of the paper, with the pen touching the paper.

The manual movements from repetier are basically sending gcode:

G1 X10
G1 Y10

Thats exactly what the crown code is doing. So if the crown isn’t working, then make sure the manual movements are right.

If that doesn’t work, posting a photo, with some way for us to tell what direction is which, might help.

That spoil board has a lot of use. This machine definitely worked at some point.

1 Like

Do you have to start on these CNCs from the bottom left or can you start in the center?

Also in Repetier I cannot see the image or toolpath of what and where it will show up when complete, how do I view that before hitting the play button?

It depends. On a dual endstop machine, it is set to never go into the negative. So that kind of set up has to be lower left.

In general though, the CAM determines where the origin is, which is where you start it. If I’m cutting something out of a blank board, I prefer lower left. If I’m carving a pattern into an existing piece (like carving on a box or a door), I prefer to center the design, so I put my origin there. The crown has it set to lower left.


Got it, the guy I bought it from demonstrated to me that it worked and he did it that way. He just did not give me the laptop (for obvious reasons) that he used on it, so I ended up with no hardware, software or anything. I think I am right about there.

Question 1- Why is my controller flashing question marks on the X, Y, and Z?

Question 2- Do I need to add endstop coordinates into the Andruino to tell it what the limits are. He gave me 4 brandnew endstops to put on the table, but I do not know how to install them yet. Thanks.

To start, don’t wprry about endstops. They don’t really help in CNC except in special cases. The ?'s are because you haven’t defined your origin.

Before you start a job, you need to set the origin. You can use the G92 command to do that. The LCD probably has an option to “set home coordinates”. This is equivalent to G92 X0 Y0 Z0.

In the crown code, at the top of the file, there is a G92 X0 Y0 Z0. So wherever you start that crown code, it will treat as 0,0,0. In your own gcode, you can choose to put G92 at the top and start at the origin or you can keep it out of your gcode and send G92 another way (from a computer or from the lcd).

1 Like

okay dumb question, do I have to use a pen for the crown or can I just carve it? I noticed that when it tried to carve it, it simply went up way too high to where it only carved three lines that were meant to be deeper (I guess). Do you have another g code that I can cut and paste that is a simple phrase like TEST with the V- router bit that I have in the machine? Heck I dont even mind cutting it straight into the MDF waste board.

The crown should only be at two Z heights, either at the clearance plane (where it’s not touching anything) or where it’s cutting.

It can be used for carving, but the crown with paper is a good test because it eliminates any load from cutting wood. Another alternative is to start with the pink High Density (HD) foam from Home Depot (or similar). This will leave crisp lines so you can tell where the bit went, but you won’t also be fighting some of the common errors while cutting wood.

I am really not sure how it cut three lines. I’d like to see what it is doing. A video would be really helpful, but a picture would also give me a lot more clues.

So I found out which gcode reader he used and showed me that worked but I cant get the download of it to work. It is CNC Gcode Controller, runs on Java. Do you have an .exe file for that by any chance?

I haven’t heard of anyone here using that. Typically we use Estlcam to create the gcode, and Repetier-Host to send it to the machine.

Okay so I loaded the firmware and got the machine talking through my computer but I only have 4 tabs in my Arduino (Marlin, config.h, config.adv.h, and boot something rather…sorry at work and going off of memory) before I had about 20 tabs. I have all those files saved to load back in there and I think that is part of the problem. My machine is currently cutting the toolpath travel path, not the actual place it is supposed to be is what I discovered.

So question, when I hit upload button on Arduino, do I have to do it for each tab, or do I need to does it automatically do it for every tab?

Also, the program that the guy I bought it from “CNC GCODE Controller” finally is opening but when I try to connect it it fails. I am on COM3 and there are two options (NR COM3 and JS COM3) I tried both and I get a M110 not responding error. I am thinking the JS one is looking for a JSON file which the guy also gave me, but when I run the JSON file isn’t working. Again not sure if that is because I do no have the other tabs uploaded.

Any suggestions? (I also added a better photo of my setup)

Then you’re done with arduino. It is only used to flash the board.

Just one time. It loads all the vode at once for the whole “sketch”, which includes all the tabs. Not sure what happened with only 4 tabs open, but I wouldn’t worry about it for now.

This is most likely a problem in CAM. Have you been able to run the crown gcode yet? It’s a really good idea to start with known cam.

So trying to do the crown. I get to the part where you select engrave and it gives me a huge patch of red like everything is backwards.