New Marlin 1.1.0 release

Today was released the final 1.1.0 marlin version. I was doing some tests with my prusa i3 clone 3 or 4 weeks ago and it’s working good. It seems that Z issues (resets) related to high speed with 1/32 microstepping is still there by some issues that I can read.

I’ll try it in a new printer I’m building (very interested in UBL new feature) in the next weeks.

Been messing with it for a few hours. So far so good here.

I’m having SD card issues. Apparently this might have been fixed in the new 1.1.0 Bugfix…Dang it

I was getting reboot looping when trying to run from S3D and then endstop activated issues (no endstops!!) running fro the SD.

So far so good with the 1.1Bugfix for me. Reading through it it was a float error, that was fixed.

What changed?

For us we get all the RC8 and 1.1 updates, since we skipped RC8 from all the weird issues that popped up. I think the most stuff for us will be LCD improvements in RC8, after that they were just optimizing code and working on bed leveling stuff. For the end user If your system works, no need to update. They did just add a cool trigger that would be good for printer cooling fans, it turns on when the steppers get activated and off when they are released, good for print cooling fans and board fans. That way when your print stops you can stop the fans and seriously cut down on dust collection, and fan noise.

RC8 implemented a lot of things but slowed down the system, then they optimized it back to where it needed to be with 1.1.

So for us anything above rc7,

1 Like

Oh and it might automatically pull in the ug8lib now, I am not clear on that part.

Thanks Ryan,

I saw this thing on the Marlin website:

As you may have seen on my MPCNC thread, I have small issues with the corners of my prints being too big, in comparison with the rest of the print.

It seems like it is possible to activate a function called “linear advance” in Marlin and set up a “K factor” to adjust the extruder output.

Do you know if this is available on the new release? Have you tried this already? I cannot find much explanation on how to enable it (but I did not even try to look in the code yet).
I believe this is less of an issue for smaller nozzles, but it could potentially make a pretty big difference on a big one…

I’m using linear advance in my printer from some time ago and it is a great improvement.

I gave it a try on my i2 clone printer this weekend. Still had to install ug8lib manually (switched computers since the last time I upgraded Marlin.) I added in the 1.1.x bugfix stuff since it looked pretty important (i.e. looked like stuff that should NOT have been overlooked on an official release that’s been over a year in the works!)

Seems to be working fine on my printer. The LCD menus are definitely improved a bit…but I haven’t upgraded my printer since RC6 - so probably nothing new for those of you on a more recent RC :wink: In fact the few test prints I did are some of the best I’ve gotten off my printer.

Then I made the mistake of trying to figure out UBL :stuck_out_tongue: The docs are a mess. I had to read through the code and a bunch of PR’s in github to figure out what was going on. I eventually managed to get it to generate a mesh, and print a G26 mesh test print…which was mostly ok but the back rear corner was really a mess…and I’m too tired to figure out the G29 P>3 stuff for refining the mesh now. So…project for later this week.

I may dig in on the linear advance stuff tonight…been wanting to mess with that for awhile.

Haven’t bothered to try it on my MPCNC yet though…heck I’m still on RC6 there as well because it’s been good enough for what I use my MPCNC for. But with an official release out I’ll probably be upgrading once things settle down. Right now though it sure looks to me like 1.1.0 will have some teething pains. But when you keep adding features to your RC’s that’s not unexpected :wink:

Yeah I’m not a developer so I don’t understand the logic behind the releases. For a few weeks prior everything worked great, I try them out all the time. Then they had a statement saying “feature freeze” just make sure everything works. That all makes sense to me. Then all the sudden right before release they changed a bunch of big things. Shouldn’t that all get added after the fact for the next build?

Either way I have learned to not jump on it right away, the first bug fix seems to be perfect for my uses on all the machines so that is probably what I will set out as the next update so we can all use a more fluid LCD. any other bug fixed will probably be UBL related and you all know I am not a software leveling fan, But I would love to try out the Linear advance stuff.

I would like to test UBL but my I3 clon has a sanguinololu board and don’t fit in the flash with this feature enabled.
I’ll test it in my new p3steel I’m building with arduino / ramps.

It seems version 1.1.1 will have some cnc specific support out of the box

I’m doing a laser run with the new MPCNC Version of Marlin 1.1 and it’s going well enough. The machine does stutter steps on the refresh interval of the LCD but it doesn’t seem to negatively affect the burn so far. I’ll give it another go in a bit and report back.

Dam. Dam. better than RC7?

Well we can turn off the progress bar, not sure if that would help because the screen still refreshes but maybe it will be a faster refresh. And/or go down to 16th stepping I am not really sure what exactly causes this stuttering but this would be less commands sent. I have the laser machine apart to put on the T8 but maybe I should go finish that up and do some tests.

Do you know if there’s a way to just turn off the refresh altogether? Once I start something it’s either go til it’s done or emerg stop if it’s failing so the LCD really is only a file loader and not needed after it starts.

Not sure about that I don’t see anything obvious for it.

You are sure it is when the screen is refreshing and not when the acceleration changes from rapid to burning? Jerk settings and acceleration can affect this, if you set the rapid rate to within 20 of the burn rate it should not stutter (de/accelerate).

I guess I don’t really need the laser on to test this stuff. I’ll see what I come up with.

Well, I see what your saying only when the screen updates does it stutter, much better than it was before though. I reflashed without the lcd…no stutter.

So now I will try some things and see what happens. Strange.