No movement X and Y, just noise and vibrations, Z fine


Just finished my Primo build, wired up steppers in series as documentation said. Without belts
installed, not much resistance moving the gantry rails around.
Now, doing a 10mm movement on X and Y, and both act the same way.
Will not “roll” just vibrates rapidly and stays put.
You know, now that I think about it, wondered if I swapped the wires on the “opposite” side motor plugs(?).
Z axis is just fine, confirmed movement is very close to 10mm when I move it via the menu.

SKR1.4 2209 drivers. Bed 1000mm x 800mm

Thanks in advance for anything to check…

Do the motors put tension on the belts? Are they actually trying to spin in opposite directions? If so, then yes, just flipping the connector at one motor or the other should correct the issue (or make the axis go in the reverse direction, at which point you can either flip both connections at the motors, or just flip the connection at the driver). Although my gut reaction is that your series wiring may be suspect. Unless you ordered a series wiring harness from Ryan, you might want to double-check those connections.

To try one motor at a time: Put jumpers on the leads for the opposite motor. 2 jumper caps on 1,2 and on 3,4. This will power only the one motor, and leave the other floating. This will confirm that it’s working.

Or, reverse the leads on one motor. A 180° rotation will have the motor spin in the opposite direction. Reversing the leads at the board will swap both motors.

Too much current can also result in no movement, just vibrating. Check your vRef values to be sure that you’re using a sane amount of current. For starters, you should be under 1A current value.

Thanks guys!
Was wondering about too fine a microstepping choice of 1/32. Changed that to 1/16 anyway, no help.
Plugged in each individual motor into the SKR 1.4 and was smooth and fine.
There must be some wiring glitch that I cannot see because of the forest! (for the trees being in the way)
So, motors are wired correctly to the four-wire plugs that go into the series adapter. And, the belts, etc are not causing binding…sometimes you just need another pair of eyeballs and I do not have anyone

Try reversing one of them, if they’re fighting each other, it won’t go well. This is why I suggested jumpers. It will move the machine, but if positive X on X1 goes left, and positive X on X2 goes right, then X1 needs to be reversed.

This vibrating happened long ago, one time as I remember. What is was: only one coil of the motor
was working. Still no success, I made a header plug 2x4 IDC pin header instead of Y-split cable, and it still is vibrating. I changed to a 12V 30A supply, from the old Burly 24V 10 amp supply. I wonder if lower voltage might be a problem???
I am considering going to dual endstops with separate motor drivers…having trouble compiling the Marlin code though.

Thanks so much for helping!
The problem was three things!

  1. There was a problem with my serial adapter, fixed it, then movement restored.
  2. Movement was still jerky and really too fast! Found that going back to 24V helped.
  3. Put dial indicated to measure the 10mm movement and the truck crashed into the indicator,
    and stopped at 23.5mm. So, it was off by 2.5x. Adjusted the steps/mm from 200 down to 80.
    Further refined it to 80.6 steps. Now smooth and quiet.

I hope my frustration and cure will help others!
Take care,
GlenB K4KV

You should be able to figure out your steps/mm mathematically fairly easily. If you know your step angle (usually 1.8 or .9 degrees), the number of teeth/mm of your belt, your microstepping settings, and the number of teeth on your pully, the maths are straightforward (I just don’t know them off hand, someone with that knowledge should be along shortly). Being off by 2.5X is odd. Being off by 2X would make sense, since you changed your microstepping from 1/32 to 1/16.

Which controller and firmware are you using? If you have ramps/drv8825, don’t skip the step of adjusting the driver current.

Do you have 20T pulleys on the motors? 1/16 should be 100 or so steps/mm.

For the recommended 16T pulleys, and 1.8° motors:

200 steps/rotation * 16X microstepping is 3200 microsteps/rotation.

1 rotation is 32mm (2mm * 16T) so that would be 100 steps/mm

20T pulleys is 40mm so 80 steps/mm

From this, I’m guessing that you are using 20T pulleys on your motors, instead of the specified 16.

If you have to reduce the steps/mm from the calculated, it usually beams that your belts are overtensioned and a little stretched. Having to increase them a little might mean a little slack and undertensioning. This can also produce some backlash or slop in the movement, so I’d take a good look at the belt tension. My Primo is dead on 100 steps/mm (At 16X microstepping)

Well, some belts out there are a little goofy with their spacing, and are a couple of percentage points off, so if you’re satisfied that the belt tension is right, and you get 80.6, then it’s probably just a little variation in the belt.

All together now - Have you checked the set screws on your pulleys are tight?

If they’re loose, that can add what looks like a little bit of backlash, which could account for the .6 step/mm error. It is better to remove the slop (if you can) than to try to compensate for it.

1 Like

Yes, 20T gears. I did not get my motors from V1. Maybe there are some weird steps per revolution motors out there.
Using 2209, UART mode. I think the firmware said something about 800ma current, perhaps 900ma.
SKR 1.4 Turbo.
The Z was correct right from the first power up.

1 Like

Geez, I must have read it wrong on the V1 site…I thought it said 20T gears, so that is what I have. I guess I would enjoy better resolution with 16T gears.

I will order 16T gears first.
Since this is rather new (had a ‘failed’ first attempt at Burly two years ago), I will check anything I can to get it right.
But, how much accuracy do I need :wink:
As they taught me in the Air Force: measure with a micrometer, mark with a grease pencil, and cut with a chain saw!

The issue between 16T vs 20T is torque, not precision. I know there are number of builds that use 20T pulleys, so it will work, but you may have to cut slower or have a shallower depth of cut compared to a rig with a 16T pulley.

Ok. That should be fine then.

You will get 25% more torque with 16T pulleys before you skip steps. But you are probably fine and can get a lot done with what you have. Glad you found your wiring bug. Those are the worst.