Noob needs help

currently have the skr 1.4 with tmc 2209 drivers tft 35 e3 v3 in the mail along with the last things i need from the shop. I am.wondering if someone can point me to a few good tutorials to get my head around the github and.compiling things so i can maybe get my cnc up and running soon. Any help.would be great just trying to.learn.

I have currently gotten everything wired up and have the motors running through pronterface. The only problem I am having currently is that my tft35 e3 v3.0 is not talking to my skr 1.4 turbo. It says no printer attached. I’ve tried changing the baud rate to no avail. I have spinne’s firmware installed on the board and the regular firmware from btt on the screen. I have also checked the baud rate set for the board and that is correct. Any suggestions of where and what to look at would be great. Skr 1.4 turbo with 2209s dual endstops with but tft35 e3 v3.0

Check you tft 5pin connector to the skr board (the one with the one pin connector seperate) i had that backwards on mine and had the same issue

You also need that serial port enabled in the firmware.

Where would I find that? Config or adv config?

It is one of the first few options in the config. On the skrs, they usually enable both of them.

OK the marlin menu is working to control the motors now, but it still says no printer attached in touchscreen. I have found the serial section. This is what it says. Not sure what I should change or if or how. lol


  • Select the serial port on the board to use for communication with the host.

  • This allows the connection of wireless adapters (for instance) to non-default port pins.

  • Serial port -1 is the USB emulated serial port, if available.

  • Note: The first serial port (-1 or 0) will always be used by the Arduino bootloader.

  • :[-1, 0, 1, 2, 3, 4, 5, 6, 7]


#define SERIAL_PORT 3


  • Select a secondary serial port on the board to use for communication with the host.

  • :[-1, 0, 1, 2, 3, 4, 5, 6, 7]


#define SERIAL_PORT_2 -1

The TFT is controlling the machine (so the machine must be receiving the commands), but the TFT thinks it isn’t connected? If that’s the case ,then your serial port config is fine. (BTW, the -1 is the USB, and 3 is usually labelled tx3/rx3 in the schematic, so that looks reasonable).

I wonder how they are deciding that. Since we don’t have an extruder (EXTRUDERS=0), it might be reading the status line, and not seeing a hot end temperature and getting a little upset.

What if you cut a small piece of tape to go over the “printer not connected” message :slight_smile:? Would it otherwise work then?

The marlin lcd is controlling the motors but the touchscreen side doesn’t do anything.

Jeffeb3 and Rob h I truly appreciate your help. The forums are an immense wealth of knowledge and amazing

1 Like

So I assume you got it working?
if so what was the fix?

Nope not yet. Just wanted to show some appreciation

The schematic shows the TFT serial port as serial port 0, not 3. I would try changing it to:

#define SERIAL_PORT 0

Yeah, it looks like serial port 3 is for the wifi port. So your wifi port will stop working.

1 Like

Schematic for 1.4 is here:

In their preconfigured firmware (for 3D printers), they set it to -1, and set serial port 2 to 0:

I would use a post-it note instead of tape. Tape will eventually leave a sticky residue…

1 Like

Bill you are correct the post it would be better but would also cover the screen. But as of now I wont be needing it. Jeffeb3 your awesome. Ryan needs to start paying you. changing the serial ports worked. Now the only thing is an unknown command: “m221” error with constant beeing. lol

1 Like

Getting same m221. Has something to do with flow percentage i thimk

i can deal with some beeping f it. moving from the basement to the garage to get it all together tomorrow.

Same here i think you can // the speaker out too