Not connecting to computer

Hi everyone. I just finished my build I am using the set up I got from this site and connected to laptop. Every thing was working good just cutting just mirrored. Checked the form today and found a post to check axis direction so connected every thing and checked axis all good. I started up a cut and was going to do some more testing set the 660 where I wanted it and restarted repetier to set home to give it a shot. It started to cut then the laptop shut down so I shut every thing down thought the battery had went dead checked that all good 100% thought that was odd. Went back for another try connected every thing back up did not connect to laptop when I plugged it back in to the same usb didn’t think much about powered the cnc back up and nothing switched to another usb and the laptop shut down again this time I know battery is good thought not good. Since then I have tried my mouse and those two usb and nothing back to the one it was in and all good. So could some thing be wrong with the board or has some thing got crossed some where some how. Any help would greatly appreciated.


Hi… I might start testing by first disconnecting the Arduino from the ramps board and plugging it into the computer all by itself. If the laptop shuts down, the arduino needs some work. If not, then connect the ramps… if it shuts down at that point, the ramps needs help. If it’s ok at this point, turn on the power supply and see what happens.

If the arduino shut down the laptop you likely have a blown regulator and it’s drawing too much power over usb. You should find that two little chips next to the usb port get very warm very quickly.

If the ramps shuts it down, then something is shorted in the ramps board and we’ll need to start looking for how that can happen… probably the diode under one of the stepper drivers. Possible the diode that you can see near the edge.

Attach a picture of the front and back of the arduino and the front and back of the ramps.

Thanks for the quick reply John. I connected just the Arduino and the light came on but did not give me a signal saying it had connected to the laptop but did not shut it down. Then connected the ramps did not shut down the laptop but still no signal saying it is connected. Turned on the power supply and connected to the laptop did not shut it down Arduino light is on but nothing from the ramps I went and checked the com port and nothing is show up tried another usb cable still nothing. I only know enough to get myself in trouble but there should be some communication right? I have attached pictures of the Arduino and ramps.

Does the usb port still work with a usb stick or other device?

The usb that it was first connected to does not work but the others do tried them with my mouse and a flash drive they read just fine.

Hmm… arduino powering up, but windows doesn’t give you the normal connection sound indicates the driver may not be working/installed… but the driver is installed because you were making cuts…

Very strange. I might try just the arduino in another laptop/computer and see if it works. If I were to guess, it will work and perhaps that means a problem on the original computer… but it would be the first time I’ve seen an arduino able to damage a usb port… something could have also damaged the ch341 chip on the arduino, but that would also be a first for me.

When you plug it in, does device manager show that there is a device plugged in?

Sorry I forgot to mention that I did try just the Arduino on another computer and still did not work. I even went in the Arduino software to check drivers and see if I could get it to connect there still did not.


That sounds like ‘buy another mega’ territory to me. I’d guess you damaged the ch341 chip and it’s easiest to just replace the mega.

If you have access to an arduino isp you could use it to check the cpu itself and confirm its the ch341, but Megas are pretty cheap…

Yeah I did some more checking and some how I fried the voltage regulator so I went on and ordered another mega. Thanks for all the help.