I’ve been assembling this and trying to suss out a few issues.

It is printing, and feels much much sturdier than my original Anet A8, however the print quality seems a little funny, the layers don’t quite line up.

I’ve returned the PID and I’ve adjusted the extrusion steps as it was way out…now I’m thinking perhaps the Z axis is off somewhere?

I’d just like to sort out the uneven layers before I start printing a MPCNC and rotary axis, I’ve got a few microswiss tubes/nozzles coming to me in the coming weeks.


Anyways, great little printer and a lot of fun to assemble, thanks Ryan!

1 Like

So close.

Just double check the settings and measurements of all three axis and do an extrusion test (on the cold side). For example, move each axis 100mm and make sure it moves exactly 100mm, and do the same with the extrusion, extrude 100mm and make sure it extrudes 100mm (measured from the cold side). There are videos on all of this if it doesn’t make sense.


From the looks of it your Z axis (different lead screws than mine) or extrusion is off (this should always get calibrated anyway).

1 Like

I’m afraid I’m at a bit of a loss, checked all my steps and they are all fine, within 1-2 steps per mm, including the extruder

I noticed I missed the screws that hold the X-Rails in but that’s all fixed now, the ends are parallel but they’re at about 300m vs 301mm, - it hasn’t made much of a difference.

The extruder clamp was also a little lose, so I tightened it up.

I’ve tried both Slic3r and Cura and no difference there.

So I’m starting to think it could be Z-axis wobble, I’ve rolled the leadscrews on a glass table and they seem straight, steppers seem to turn straight, one coupling could possibly have a little wobble on it, but it was very difficult to see, and I’m still not sure if it’s there. Is it possible the brass nuts have slop in them? I’ve taken them from the anet and have been printing with them for probably…100-120hours?


All very puzzling

I love it. Looks like a good build.

Ryan’s tight that you are probably close. You’ve got 1-2 problems left and then it’s just some fine tuning. The problem is that there are several places that the last problem could be.

Have you looked closely at the couplers on the Z? You can couple it out of center, which can cause wobble. Do you have grease on these leadscrews? If you ran then that long without grease, I could see the nuts having been worn down.

You mentioned you didn’t have those screws in holding the x axis rods in place. How is your x and y belt tension? It shouldn’t be as you as you can get it, but it should make a noise when you “pluck” it.

Something that was just giving me trouble was the spool was pulling on the extruder and causing it to too up and down. You can just make sure the printer has enough slack when printing to test this. If that’s the problem there are a few easy fixes.

Did you do the extrusion test, 100mm?

What material are you using, and what temps are you printing it at and what speeds? from what I can see it looks too hot or over extruded but if you tested the extrusion…

Within 1-2 mm over 100? 1 is bad 2 is horrible. It should very easily be basically dead on within .3mm

Do a temp test tower, too hot and it could look like that. Print something larger, the picture you have isn’t super clear on what is going on.

I had it working much better last night…then the computer crashed as it was uploading and I was silly enough not to save my modified settings. All is well though as I now know what I’m doing.

The step setting was off by 1-2 steps as in, by my calculations I was somewhere around 397 steps per mm (1/16th stepping) and should have been around 396-9 - I’m not sure if this is visual error on the ruler or not, but it looked like it was extruding 100-100.5mm

Once this was set, I played with the extrusion multiplier and had improvements over extruding (1.1 looked a bit better than 1.05), which seems a bit odd to me.

However I did notice that I was getting slight curling on one corner of the 20mm calibration cube which I’m putting down to too much heat. The top layer also looked under extruded.

Tonight I’ll try loosening up the belts, I did tighten them as it looked to me like I had too much slop in the belt, and the X-axis would sometimes grind and stutter in one direction before tightening. Maybe I’ve gone too far.

I’m printing at 210 degrees, I was using 220 on the esun PLA, however this is Winbo filament, which I printed the parts for the MP3DP with at 220 degrees on the Anet.

The spool is a bit of an issue, but even if I ensure there is slack in the filament the problem is still occuring.

I’ve been running the anet with lithium grease and crc on the Z-rods, so they should be in reasonable nick, I’m wondering if the Z-nut isn’t fully pressed into the X assembly, from memory it was a fairly tight fit to get them in, it might be worth disassembling it and sanding the top of the printed part flat and reaming out the inside where the nut fits so it’s not contorted in anyway.

I am loving seeing how all of this works, and again thank you both for all the help!

X Y and Z are real whole numbers and should need no tuning. You just need to verify they are correct. If you are using my firmware and my parts these numbers do not and should not be changed. 200mm should equal 200mm on all three axis. But I do not think this is the problem. (side note, the z nuts should come in from the bottom)

Do not tune your extruder with an extrusion multiplier, fix the firmware. Again if you are using my recommendations this will be very close but it actually does vary according to the type of filament and how tight you have your spring.

You don’t have to guess about temps, print a temp tower found on TV. The PLA I use ranges from 196-213, 220 sounds extremely high.

I finally got there…Thought I’d follow up in case anyone else is having similar issues.

Adding the microswiss in the mix complicated things a bit, but to be honest even after all the setup, it was definitely worth it.

Had heaps of adhesion problems, I eventually moved to an aluminium heatbed, which seems a lot flatter than the other bed I was using, but it still required manual mesh bed leveling,

I upgraded the springs to something a bit heftier, which killed the wiggle I didn’t realise was there, I then later noticed the bearing clamps on the underside of the bed weren’t very snug and were introducing some weird movement too, after correcting all that my problems have gone and I’m now printing parts for the Lowrider V2!