Odd pausing behavior from CNC

The past few jobs I’ve tried running (different files) the CNC seems to be pausing or hesitating after making a few cuts. I suspect it’s the Pi4 that I’m using but I’m not sure. There should be plenty of horsepower to handle processing the commands but I couldn’t find any other threads that mention their CNC behaving the same. I’m just wondering if anyone has any suggestions of things I could do to narrow down the culprit. I’ve tried restarting the Pi by executing the “sudo shutdown” command. I’ve also power cycled the Archim control board. I’m more than happy to supply any additional information that would help to solve the issue.

I would start by running from the USB or an LCD screen. Figure out if it is a Gcode issue or your Pi.

The pi4 should be very happy sending gcode fast enough. The bottleneck is going to be the USB to serial port (unless you are also cryptomining or something).

Ryan’s suggestion is good. Try it with Repetier host and USB on a full computer, or try the SD card in an LCD and see if you can see any difference.

Ok, I’ll check both of those scenarios today and report back. I had similar suspicions given what I already know about how everything works together. Thanks for taking the time to help me sort this out.

Hey guys, before I could test the solutions you gave me the cnc started to work just fine… As of yesterday however its back to the weird pausing… I took a video that clearly depicts what its doing. As I mentioned this was a job I started from CNC.js on a Raspberry Pi 4 loaded with the V1Pi image. Nothing else should be running on there. I tried a different USB cable but that didn’t make any difference, I also tried to run a job off of an SD card but the card I have must be too big so I need to fine one that the Archim board can detect. If there is something specific about my setup that might be beneficial to this issue I’m more than happy to tame more pictures to share the configuration.

https://photos.app.goo.gl/WXwwTnXDTmwhaFd4A

Best to do any tests with the test crown gcode to rule out any file based issues.

So I’ve tried loading the gcode onto an sd card but the display keeps saying no media, even if I click the button and it reloads. But when I pull the card it says media removed. I did however try to run the gcode from CNC.js and it’s pausing there the same as when I run my other jobs. I am using a 64GB SanDisk Extreme Pro card that my wife uses for her photography business so it’s not a bad card. What format does the card need to be or is there a size limit on cards? Otherwise, I was wondering if there was any chance the Archim board is somehow damaged from me slowly moving the gantry around while it’s powered up. I know the stepper motors can generate power that flows back to the board but I’ve always done my best to move the core slowly in order to prevent that from happening.

New fast cards are not very compatible with the older LCD’s. 2GB or less are ideal 4-16bg usually work, with the newest firmware v510. The lower the rating the better, class 10 are finicky sometimes.

Using a smaller 4gb sd card that came with the Maker Select Plus printer worked. Also the Test-Crown-12mms.gcode ran fine without any pausing when I ran it from the SD card but when I ran it through CNCjs it had lots of pausing between movements… So I’m at a loss… Is there a chance something with the v1pi image is messed up? or maybe the Pi itself is the problem? I tried 2 different cables and neither eliminated the issue. I’m not a command line wizard… I tend to cause more problems the good when I start poking around lol but to my knowledge I haven’t done anything in the command line since I flashed the image last…

I am unfortunately not familiar with cnc.js at all.

would you agree it seems to be cnc.js or do you think it could be the pi? I have a second Pi 4 I’ll swap out to see if that makes a difference.

Well the other brand new Pi 4 pauses mid job a ton too… so then it must be the communication between the pi and the archim?

I would suspect the usb cable and the sd card is a lot faster, so if there are a lot of short commands, then the serial over usb connection can be a bottle neck, and the consequence is short pauses.

Would it matter if I’m using the usb 3.0 port on the Pi 4 or not? I did try both ports and had the same results I’ll see if I can find another cable otherwise I can just order a new one

I don’t think so. But maybe.

Here is the cable I purchased https://www.amazon.com/gp/product/B00P0FO1P0/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1 However I’m still getting occasional hesitation in the movements. Is it possible the Archim board is getting interference from something else? Are there some do’s and don’ts that I should verify in regards to how I have everything wired up or positioned in relation to each other?