Only EstlCAM can speak to the Ramps 1.4

I am trying to sort out a number of issues including setting a Z max endstop to allow proper homing. My MPCNC is on Marlin downloaded from here on Mega 2560+Ramps 1.4 and will run on EstlCAM and I can move it around and run Gcode with it, indeed, I have run quite a few jobs on it.

I can’t get anything other than EstICAM to connect with it. have tried just about every other Gcode sender I can find to try and connect with it to be able to use other commands and nothing will work. I have tried:
Repetier Host
Repetier Server
Universal Gcode Sender
and some others but they will not complete a connection. They say something like

Mesg:18:09:40.581: Connection started
Mesg:18:09:40.581: Printer reset requested false
Mesg:18:09:40.597: Dtr: true Rts: false
Mesg:18:09:40.628: Dtr: false Rts: true
Recv:18:09:43.642: Send init commands because we had no signal from a reset, assuming reset not available.

I need to know what the switches are doing to set the Z max as when the machine tries to home the Z axis runs away looking for an endstop and will try to lift the Z axis to about 8000mm (!) before quitting. This is obviously making homing just about impossible but EstlCAM doesn’t know the M119 command.

Does anyone have any ideas why I can’t connect?



That is because Estlcam has flashed your Mega2560 with its own code in order for Estlcam to work. If you want to re-use a different sender then you will have to re-flash your Mega2560 with Either Marlin or GRBL.

There is a restore Controller option in Estlcam -setup- CNC Controller- controller tab but it is not particularly reliable. You could try that option first but if it doesn’t work there is always Arduino IDE!


or you can simply flash the firmware from v1engineering also. But as stated above. It is not really marlin anymore.

Thanks guys, I will give that a go.


Hmmmmm No joy.

I flashed the latest edition of the V1 Ramps firmware using Xloader and I still could not connect. Not sure what is going on. Am I being spectacularly dumb and missing something obvious??


So if that worked, then I am not sure what the problem could be. As Xloader uses the same usb cable that you would connect with.

from the panel on your ramps, can you tell us, does it say Marlin. (Not sure what it would say if it was flashed with Estclam.) But, Estlcam is not supposed to be able to connect to it.

Did Xloader say it completed successfully??

I notice you have installed Repetier Server and Repetier Host on your computer. So you actually had 2 problems… the first was Estlcam reprogrammed your mega2560 and the second is Repetier Server has grabbed your serial port and wont relinquish it to another application, this is a well documented problem I suggest you uninstall Repetier Server and try again using UGS or prontaface.

As long as you don’t install Repetier Server, you can use Repetier Host.

1 Like