Only one Y motor turning SKR 1.4 (not turbo) TMC 2209 MPCNC Dual endstop

Hi All

I am building an MPCNC primo (dual endstop), and an having issues with the firmware.

Am using SKR 1.4 with TMC 2209 V1.2

This is the firmware I downloaded from V1:

currently I have the X axis working and z axis working but only one Y motor working

I have downloaded several different versions of marlin and have had the X nd Y axis working but the Z moves while making a high pitch whine, I downloaded the Firmware from v1 engineering and it cured the whine but the Y motor stopped turning.

I know its something in the marlin software just don’t know where the bit of code I am having problems with is.

So you have an skr 1.4 turbo or the not turbo (I hate that they have one with no lavel). I don’t know if we have tested it with the skr 1.4.

Things I would try are:

  • M122. Does that show the 5 drivers? Are they all talking?
  • post a pic of the board so we can see if there are any obvious mistakes.
  • swap things out. Move a driver to a different socket. Try the y wire/motor in a different port. Remove the endstops completely.

Every time mine did this it was a bad wire connection at the board. I ended up replacing the plug on mine to fix the issue.

Its a SKR 1.4 (not turbo)
How do you do M122, don’t have repiteir host just the mpcnc and firmware
Pulled out the endstops and that didn’t change it
Swapped the motors round and the motor worked in the new spot and the motor put in the no working position stopped working
I have also had different motor not turning with different firmware loaded, so its definitely code.


I hope this helps, have been working through this problem and looking through the marlin code learnt a lot, but still frustrating. I’m suspecting that the motor information is not being sent the the stepper driver hence it not working. I checked the pin numbers in the 1.4 file and they seem correct.

Swap the two drivers… and check again?

Checked that before, and just rechecked it’s not the drivers they are working fine.

Did you already check the solderjoints on the underside of the board (both driversockets and headerpins for the cables)?

That is fine, as I said above I had other firmware in that had the motor running,
the issue there was that it made the z axis motor make a high pitch noise with a partial run, so I changed the firmware now this motor won’t run.
I also had the no run happen on an x axis motor with a different bin file.
Which means at some point they have all been operating properly. The kicker is not at the same time,

this leads me to conclude it’s a firmware issue

I missed the first part. As I understand, you are using 1.3 firmware on a 1.4 board. If so, you probably have to alter boardname in configuration.h (near line 132) and check the pins-file and compile the firmware yourself.

Pin numbers on the two boards are different.

The firmware I got was from here:

Looked up this:
The BigTreeTech Skr v1.3 or Skr v1.4. These boards are smaller than the Skr Pro, and has 5 drivers, not 6.

Then Downloaded this: / 510 [untested]

I Know the 1.4, use them for my MP3DP and my trusty Delta printer. The 1.3 and the 1.4 are not pin compatible afaik, so then you get the firmware for the 1.3, you have to alter the firmware. Checkout BIGTREETECH-SKR-V1.3/SKR-V1.3-PIN.pdf at master · bigtreetech/BIGTREETECH-SKR-V1.3 ( vs BIGTREETECH-SKR-V1.3/BTT SKR V1.4PIN.pdf at master · bigtreetech/BIGTREETECH-SKR-V1.3 (

1 Like

I checked and realised it says 1.3, changed it to 1.4 am now getting the following errors

#error “X2_USE_ENDSTOP has been assigned to a nonexistent endstop!”
#error “Y2_USE_ENDSTOP has been assigned to a nonexistent endstop!”

I think this means the pins file is wrong?

// TMC StallGuard DIAG pins


#define X_DIAG_PIN P1_29 // X-STOP

#define Y_DIAG_PIN P1_28 // Y-STOP

#define Z_DIAG_PIN P1_27 // Z-STOP

#define E0_DIAG_PIN P1_26 // E0DET

#define E1_DIAG_PIN P1_25 // E1DET

I think this looks like the location

I’m afraid you’re in uncharted territory. I don’t have a 1.4 board, and I’m not sure what pins those should be set to. If you figure it out, we can document it here, and link from the software release page.

Going off this they don’t look correct but I could be wrong

Sorry wrong image they are correct

This is not the setting… Stallguard is the sensorless homingthing in the TMC drivers. I assume you have removed the diagpin from the drivers? Else they can interfere with the endstopswitches…

If you mean this pin then yes