Post Processor for Fusion 360

I’ve spent a couple of hours in Fusion 360, and had a problem with the Post Processor wanting to drag the cutter across the work surface from the start! After pulling out most of my remaining hair I finally got the post processor to work the way I wanted and that is to raise the Z axis to the clearance height. It really shouldn’t be this difficult but!!

In any case if anyone is interested in a copy let me know. Can’t seem to post any files other than graphics though I have seen other file types on here.

This is NOT for Marlin, it’s intended for use with Grbl .91 and above.

I thought the guffy post processor worked with grbl. Guffy does a good job of maintaining it.

1 Like

I would be interested in seeing the changes you made to the post-processor.

I tried it but it didn’t work, nor did any of the others that I tried.

1 Like

The guffy GRBL post processor definitely works as there are people on this forum using it and asking questions about it. You do have to install both the PP and the common file to make it work.

I didn’t see anything regarding a “common” file. The Zip file only had one file in it, “MPCNC” from Sept 11, 2015.

Here is a link to the guffy github post processor page. You will be installing DIYCNC_Grbl11.cps and DIYCNC_Common.js if you are running GRBL.

1 Like

That is the one I tried, though I didn’t do anything with the Common.js. Don’t really know how to use the common file.

You don’t do anything with it. Just put it in the same directory as the DIYCNC_Grbl11.cps file.

Edit: Most of the people on the forum use the Guffy post processors, but that does not mean the post processor configuration that you have setup might not be as good or better.

This is all I get!

It has been 18 months since I setup guffy post processor for Fusion 360, and I’m running Marlin. All I remember doing is following the instructions here, and putting the two files I mentioned above in the specified directory. I was helping someone last week debug a problem in the GRBL version of the post processor, so I do know for certain that the GRBL post processor requires DIYCNC_Common.js.

Edit: I just looked, and I have the GRBL post processor installed on my laptop as well as the Marlin version. Not sure why. Both are installed in: C:\Users\rober\AppData\Roaming\Autodesk\Fusion 360 CAM\Posts. I was able to select the GRBL version and output a g-code file.

Well isn’t that strange, I can’t get it to work!
This is what I get.

All I can suggest is a redo:

  • Download fresh copies of the guffy post processor files
  • Move everything in the C:\Users<name>\AppData\Roaming\Autodesk\Fusion 360 CAM\Posts file to a new location (or delete them).
  • Verify that Fusion can no longer find the files
  • Place a fresh copy of the guffy post processor in the subdirectory
  • Test again

Thanks, I think I’ll just stick to the one I created since it appears to work so far anyway. I may look at the Guffy one again tomorrow.

Cheers!

I thought Guffy maintained a pretty good github repo for it too, with issue tracking and instructions. But I haven’t ever used it myself.

Here is the Fusion 360 Post processor that I changed. V1 LowRider2.zip (7.1 KB)

Again, it’s meant for a Grbl controller at this point.

Well I went to the github page and downloaded the file again, that’s different then the one I had before and surprise… it worked as well. :wink:

1 Like