Primo in Pittsburgh

Patrick here, this forum has already been helpful with this build. Thanks.

I finally have a little bit to show, but I guess some background would be good. I have a small carpentry shop with focus on wooden boats. I also do carpentry in people’s houses, built-ins, cabinets, railings, etc. I’ve wanted a cnc machine for a few years now. I decided to see if I could learn some cad/cam first and have been successful modeling a few things. Because of that my wife got me a 3d printer for Father’s day. It’s a Voxelab Aquila. I printed some of the things I designed and also started looking at the mpcnc. I actually looked at a few other printed designs but the community and success rate here made the decision for me.

Anyway, most of it is printed now and my stainless tube arrived the other day. I took it to my shop and cut it to length. I used my metal bandsaw and that went quick. I picked up the stainless from one of my suppliers Fisheries Supply in Seattle. It’s 1" polished…065 wall.

The prints are all hatchbox pla. 55% infill, .26 layer height.

The work area will be 20 x 18 x 3. Thanks for looking


Looks good so far!
Building everything is certainly a process, but you seem to be on the right path. Just keep at it and you’ll have a wonderful tool to add to your arsenal.
If you have any questions, don’t hesitate to ask, everyone here is crammed full of knowledge and advice.

1 Like

Thanks, so far a fun adventure. Core printed over the weekend with no issues. Just a few parts left including the spindle mount for makita 701. The kit from v1 should be arriving today and I can start assembly.


Very nice shade of blue, I did a brighter “electric blue” with my build. What size stainless tubing are you using? That looks pretty!

Thanks! It’s 1" stainless…065 wall

1 Like

Ack! I was going to make a completely off-topic remark that tied into my one-semester at CMU, and found that The O closed last year! Yes, It was 35 years ago, but I still remember going to get O Fries with the folks from the SCA after one practice or another. I also remember hanging out in the studio of WRCT (“Corrupting Pittsburgh’s Youth Since 1949” was the tag-line at the time) watching the DJ’s do their show in their underwear, spinning mega-mixes of Abba and Yngwie Malmsteen. This was also long enough ago that the engineering graphics course I took was 100% analog. No CAD, yet. Of course, I spent too much of my time in the Tower of Ignorance at Pitt, chasing aforementioned SCA folks, and had to return after a semester…

I’m not from here so I don’t know much about any of the places especially the college scene but I’m sure my wife would know all of them. I’m south of the city about 10 miles. And luckily don’t have to go there too often!

Got a couple hours yesterday evening and was able to get mounted to base, squared and leveled. Also got the trucks put together and installed. Stopped at squaring the trucks. Will be on that next. Might not get to until tomorrow evening. Printing router mount today. Downloaded an lcd enclosure and will print that too. Then I have to figure out wire management and what I might need to print for that.

Three words: tape measure trick

That’s mainly what I’m looking at. I’ve got a bunch of old tape measures, mostly 1". Looking at the wire sleeve now. Thanks for the link!

Still looking really good!
A bit of advice before you get too much further along, check and make sure all of the bearings in your trucks are making contact with their rods. You have to remove the stepper motor to make an adjustment (at least I had to) and its much more simple to do it right the first time, lol.
I had good contact with most of the bearings on my first go-through, but didn’t check all of them. I only did the slide check to see how quickly the truck would move on its own. Still had some loose bearings that started chattering when I ran it.

Thanks, I’ll definitely give them all a check again. No chatter at the moment. I squared up the trucks and got the core and z assembled last night. I may need to add a little more tension to the core but at the mement it seems good.

Hopefully get the electronics hooked up tonight and test movement. I printed the lcd case and am currently printing the rambo case. Just need to order some wire loom/sleeve.

I couldn’t find an answer that sounds like what I need so I’ll ask here.

A couple things…

I have the electronics hooked up. I can control motion with the lcd hooked to the rambo board. I have repetier host on my Ubuntu laptop but can’t get it to connect.

I have the dual end stops but can’t get it to home. Z home works well with the probe . X home only moves about 5mm and stops. Y does the same. However with the Y it moves away from zero. If I swap the plug so it homes toward 0, it draws the crown upside down.

Anyway, I did get a crown drawn, seems off a little but was fun to watch the machine working!


Is your user account added to the dialout group?

1 Like

I don’t know honestly. I saw that in the instructions but don’t know how to do it

If you are a point and click type user, I think there is a user menu in the ubuntu settings.

Otherwise I think it is:

sudo usermod -a -G dialout boatshop

Thanks. I did that in terminal. No change in repetier though.

Another odd thing. I tried to process my own drawing in estlcam. When I start the print, it raises up about 30mm then stuttered as if it’s stuck.

By the way under the port list in repetier, I can see the usb-ultimaker option. It’ll disappear when I unplug ND reappear when I plug back it.

OK, got estlcam working. I think it wasnt saving the control file or one of the settings was wrong. Working well now. Adding a picture it drew. A little while back I traced a catboat drawing. I like how it looks like and old drawing and think it would look nice carved in wood.

So, still no computer repetier connection and I can’t figure out the homing. I also switch the x steppers so it would draw the crown in the order it drew everyone else’s. Now when I try to home x or y they just move a little bit away from 0.

I usually use

sudo adduser your_account_name dialout

You’ll have to log out and back in again for it to take effect (a reboot works too).

1 Like

Thanks, I managed to get that to finally work this morning. Can connect to repetier and cncjs now.

So I can finally send m119 and I get triggered on x and y’s. Z is open. Z is triggered when I touch the wires. No change in x or y when I hit the switches. I read the crimp can be weak. Likely all 4?

So if I take the switch wiring off and short the two pins on the wiring harness to the rambo I get an open status. Shouldn’t I get open u shorted and triggered when shorted?