Printing from an SD card

I have my rig up and running.
All the parts were purchased here with the exception of the LCD.(Purchased here ;http://www.banggood.com/3D-Printer-RAMPS-14-LCD12864-Intelligent-Controller-LCD-Control-Board-p-922875.html)
I can manually move all axes with the LCD and I can print using Repetier on my laptop.
When I turn on the machine the LCD shows the Marlin logo.
I want to use the machine with a spindle.
What do I have to do to get it to print from the SD card slot on the LCD control?

Thank you in advance

You can use ESTLCAM to generate your gcode, save it to the SD card, when you put it in the LCD just hit print from SD and select your file.

Does it need a certain file extension? I know my 3D printer needs it saved as G code to work.

Look through the Forum here, You need a post processor and it saves it in the correct format and extension. I don’t use fusion so I don’t have any experience with its post processor.

You might want to run through the ESTLCAM walk through first to run the machine and make sure everything is working as expected. Custom post processors can be complicated.

Thanks for the quick response. I am not sure what a post processor is. I created a file and saved it in ESTLCAM, opened it in Repetier host and was able to run the file from my laptop. I even saved it to an SD card from repetier but could not get it to print.

Couldn’t get the file to print from the SD card how, in the LCD screen, what happened?

You can always generate the part in fusion and use ESTLCAM as your CAM processor. If you want to use fusion for everything try this thread, https://www.v1engineering.com/forum/topic/fusion-360/.

A post processor is what formats the gcode properly for the board that will run it. Things like // or ;, and how the coordinates are sent one at a time x then y then z, or xyz.

Luckily someone has taken care of that and it is fully functional as far as I know for fusion, and found in the linked thread.

The LCD screen recognizes the sd card and even lets me select the file but the machine doesent start.

Using the same exact file you load into repetier? I have never heard of this.

I have had this issue as well. I loaded the file to a different SD card and it worked. The one that did not work for me was only a 16MB card and did not have any class marking on it.

I am currently using a Kodak 2GB card (but there is still not a class marking on the card). I would suggest trying a different SD card.