Problem with Fusion and Z feedrate

Hello and greetings from Finland!

I am trying to generate gcode from Fusion with guffys post processor. For some reasons Z feedrate in gcode seems to be the same than with X and Y, in my case 720mm/min (cutting rate from fusion feed&speed) . So neither the Travel Speed Z option in post processor nor max Z feedrate in Machine Kinematics in Fusion are working. They both are set below 400mm/min. This is my first time trying to create gcode straight from Fusion so I cant tell if this is something to do with the newest Fusion update or what. Plunge speed limit seems to be working but it only limits plunge moves. Anybody having the same issue? Or is this even anything to be concerned about?

The other issue I’m having is that the first move from machine 0,0,0 to entry position does not take retract or clearance heights into account and is dragging the surface. This is something I can fix manually by lifting the machine after setting z=0 but it’s against the idea I think.:D.

Also tried the other post processor, martindb’s, both issues appear also with it so probably Fusion is the problem?

I used Estlcam earlier succesfully but my current project includes a lot of difficult 3d shapes and various toolpaths so Fusion would be better I guess. If it worked.

1 Like

Here is the beginning of generated gcode:

;Fusion 360 CAM 2.0.9009
; Posts processor: DIYCNC_Marlin20.cps
; Gcode generated: Tuesday, 6 October, 2020 10:40:51 GMT
; Document: Akustinen Kitara1 v14
; Setup: Setup2
;When using Fusion 360 for Personal Use, the feedrate of rapid moves is reduced to match the feedrate of cutting moves, which can increase machining time. Unrestricted rapid moves are available with a Fusion 360 Subscription.
;
; Ranges table:
; X: Min=-317.209 Max=6 Size=323.209
; Y: Min=-317.209 Max=6 Size=323.209
; Z: Min=-18 Max=5 Size=23
;
; Tools table:
; T1 D=8 CR=0 - ZMIN=-18 - flat end mill

; *** START begin ***
G90
G21
M84 S0
; *** START end ***

; *** SECTION begin ***
;Bore1 - Milling - Tool: 1 - flat end mill
; X Min: -6 - X Max: 6
; Y Min: -6 - Y Max: 6
; Z Min: -18 - Z Max: 5
; COMMAND_START_SPINDLE
; COMMAND_SPINDLE_CLOCKWISE
M0 Turn ON 11999RPM
; COMMAND_COOLANT_ON
M117 Bore1
; MOVEMENT_CUTTING
G1 X4 Y-0.8 Z5 F720 // dragging is not problem here because travel is short but the problem exists
G1 Z2 F720 // this is too fast
; MOVEMENT_LEAD_IN
G1 Z0.8 F720
G1 X4.004 Z0.722 F720
G1 X4.015 Z0.644 F720
G1 X4.034 Z0.568 F720
G1 X4.061 Z0.494 F720
G1 X4.094 Z0.423 F720
G1 X4.135 Z0.356 F720

1 Like

Can you post screenshots is the speed panel for the toolpath?
New restrictions on the fusion personal license will limit all travel moves to the cut speed, but it shouldn’t speed them up. That’s really odd. Of course, fusion releases updates every month with a list of bugs they fixed, soooooo…

As Tony suggested, my first thought was Fusion 360’s changes to feedrate for their personal use license. If it is a Fusion 360 bug rather than an issue with your settings, you might be able to work around it by inserting an M203 command in your gcode file. Note this command takes units per second, not minute.

Just in case this is a useable workaround, you can set the maximum feedrate in Marlin with M203. That will make your max Z speed for any moves limited to that value.

The gcode should be right, and I haven’t seen this particular issue with fusion complained about before, but if you’re just worried about the top speed, then you can limit that in the firmware.

Thanks guys, have been reading Autodesk forum and it seems that several post processors are broken because of the new restrictions.

I will try the M203 next.

1 Like

adding g92 will make it so you machine thinks it is at 0, 0, 0

sorry I forgot the add the full command is G92 X0 Y0 Z0 or just G92 Z0 for the z axis

Hi Guys,
I am having the same issue. It is because fusion took out the rapid movement.
How it was working before it used G0 and the postprocessor was able to seperate the xy and z axis for moves that not belongs to any operation. But now fusion is saying all these movements counts as cutting movements and now the postprocessor can’t seperate them, so all the axes using cutting feed rates. It is super annoying since my (and might everybody?) MPCNC Z axis can only go as fast as 300 mm/min