Problem with Marlin-Vectric post processor


I have been designing in vectric and outputting Gcode using the Marlin pp.


The problem I have noticed that may be of help to others is:

  • Commands output at the start of the file

begin HEADER

“; Safe Z height: [SAFEZ]”
“; Tools: [TOOLS_USED]”
“; Notes: [FILE_NOTES]”
“; Generated [DATE] [TIME]”
" "
“M84 S0”
“M03 [S]”
“G00 X0.000 Y0.000 Z0.000” =============THIS LINE HERE===========
“G1 [SAFEZ]”
“G1 [XH] [YH] [F]”
" "
“; Tool [T]: [TOOLNAME]”

If you protect your spoilboard by using z zero as the bottom of your job you are going to have fun with that line as the cutter plunges through your material.

How do I know,put it this way- my emergency stop works…

I just removed the Z0.000 from that line in the pp.

I use the bottom sometimes as my zero, with vectric, never had the issue. The only reason it would plunge down is because it thinks the home/origin is lower than where it is, since that line is telling the machine to go to the home/origin position. Do you have a sample gcode file where it does this? would be interesting to take a look.

I could be misunderstanding the question here but I think I ran into a similar situation the other day as I was setting up my machine for the first time use with the pen and crown test. I was tweaking marlin settings, compiling and uploading to the board to get the right behavior. At one point I tried using Zmax for homing and had the machine home Z up instead of down. I assumed it would set Z0 to this point but I was wrong. Instead it thought that was Z200 since the firmware thought it was 200 mm tall. So after I homed it and told the machine to go to X0 Y0 Z0 it also smashed into the bottom.

Maybe you are running into a similar issue. I don’t know.

I switched back to using Zmin and am not currently using an end stop for it. I will eventually create an aluminum homing touchplate like the one featured in this video. Although I only plan to use it for Z for the most part. It could be used for X and Y offsets.