Problem with the X motor

Hi all,

Before joining the pieces of the LR2, I tested the software of the MiniRambo card and the connections with the motors.

Apparently everything works correctly, except for the motor of the X axis that produces a rare noise, and barely moves. I have recorded a video to show you the problem:

I have also tried to change this motor whit another one, and the result is similar.

Is it possible that the X motor wires are misplaced?

By the way, the rest of the motors (Y, Z) work fine!


Swap the steppers, check the wires, verify they are wired into the plugs correctly.

1 Like

There are tests for stepper motors if you have an ohj meter. Each coil should have about the same resistance and when you close a circuit with one coil, it will resist turning. Don’t do these tests while the stepper is plugged in and don’t disconnect a motor while the driver has power. You should also be able to rotate the motor by hand when it’s unpowered. Steppers are really hardy though, so you can probably fix it.

1 Like

Thanks, I’ll check the wires next weekend. Anyway, the motor came already with the connectors placed, and the X motor does not have any special wiring in series, so I have doubts that this is the problem.

I suspect that maybe it could be a problem with the Mini-Rambo board. I bought the card in amazon, and it is possible that the shop was not very confiable… I have seen that other people have had similar problems with the motors due to the board:

Maybe that’s the problem. Anyway, I’ll check it next weekend and I will notify if there is any progress!

1 Like

Hi all,

I made some progress with this problem during this weekend. I checked all the conections of the motor and everything is correct.

However, I tried to check reducing the voltage of the power supply, from 12V to 9V, and with that configuration the X-axis motor started to work … more or less. Although it was advancing in the direction indicated, it sometimes made sudden leaps… so this is not a solution…

During this week I will receive the new Mini-Rambo from ultimachine, and I hope that these problems will be solved.

Finally the original Mini-Rambo solves the problem, and without change anything else the LR2 works fine.

thanks for the tips!

1 Like