Problem with Z homing

Good day everyone,

so im having a problem with the homing of my Z and can’t seem to find the answer. So I’m looking for help/advice, So my machine is a Ramps 1.4 board with a 500w spindle. I have the ground for the z limit attached to the bottom of my spindle with a screw, and I have made a touch plate with a filed knife blade. It’s been filed to the point of removing any sharp edge. So no worries I’m not got to get hurt from it. But anyways here is the problem I’m having.

 

When I have my spindle unplugged from the AC power, and tell it to home the Z the spindle comes down touches then goes back up and touches a second time only slower. Which is the correct way it should work as I under stand it.

but

when I have my spindle plugged in (not spinning) and tell the Z to home it travels down and touches the plate once then travels back up like it should, but only comes back down about 75% of the distance to touch a second time.

And

if I reverse the Z limit wires on the Ramps board the spindle doesn’t even touch the plate.

 

so any ideas on what I can do to make it work properly without having to unplug the spindle from the AC power each time.

 

 

Your spindle and ramps aren’t on the same ground, or there is noise on the AC ground. The spindle’s body is connected to ground, and that’s good. It’s a safety measure. But it’s not exactly the same ground.

I would just unplug the router before probing. I would be careful because you’re also grouding it through your ramps. I would also disconnect the homing wires before plugging in the router to AC.

Hi Jeffeb3,

i do have the Ramps and the Power supply both plugged into the same outlet, but saying that just made me realized that Ramps only has 2 wires + & -.

Wow can’t believe I missed that one. you would think as a power engineer I would have made sure that both grounds where connected, And I figured it was a noise interference but lately all my trouble shooting skill have kind of been off for the last month or so, I bet it has something to do with the birth of my first kid. Must not be getting enough sleep.

Im going to add another grounding wire from the spindle to the AC power supply for it and see if it solves my problem. If it doesn’t then disconnecting and reconnecting every time will solve it for sure.

thanks Jeffeb3 for the nudge in the right direction.

I attached an alligator clip to the ground of my probe wires, then just clip it on the endmill. Way easier and takes out the funkiness of trying to get a good ground through the motor.

I didn’t get a chance last night to try connecting the grounds, As I ended up spending a couple hours with the baby.

in the end thats probably what I will end up doing, but I was just hoping to keep it attached permanently and that way all I would have to do is just put the plate under it.

Are you implying that your MPCNC isn’t your baby?!? @vicious1, grab the banhammer!!! :wink:

You read that wrong…

2 Likes

Lol I have lots of baby’s in my house. My 48 Chevy truck is one, my metal milling machine is another, my metal lathe and my wood lathe are each one also, and the wife and 5 week old daughter, and the 3 3d printers and also mpcnc, but unfortunately I was only referring to the 5 week old I was spending time with last night.

And your right Ryan she will learn how to use the mpcnc at some point, and she will probably get better then me at using it in a way shorter time frame then it took me.

Also, Pro Tip. When she’s a little older, kids love to sweep.

Thanks for the link, but some friends of my wife already got her a set before she was born. which i thought was great because then I can take her into the shop with me. In the future I’m not going to leave her to not knowing how to change a tire or how to boost a battery on a car. If she knows that stuff then she is less likely to ever be stranded.

I will keep that tip handy for when she gets a little older. The shop can always use a extra set of hands for clean up.

My 5 y.o. always wants me to disconnect the dust collection on the table saw to give him more to sweep.

Lol that’s awesome

It is. I waited too long. Mine are 13 and 16, and the eyerolls and sighs are seismic when trying to get them off their computers to go out to dinner.

My older brother took away electricity from his kids one week. Went to the basement and flipped the breakers to their rooms!

We had the power go out for a few days when I was a kid, during an exceptional snow storm. Probably out for 2.5 days. I wonder now if that was actually my dad teaching us a lesson…

We played a ton of board games and we got pretty good at tiddly winks.

Oh, the ONLY electronics in their rooms are their alarm clocks (well, we let them run humidifiers and air filters, too). Not even phones go upstairs. Computers are laptops set up in the formal dining room. Which reminds me, I need to get some button cams…

As a family, we’re too competitive. It starts as fun and games and good-natured trash-talking, and before you know it there’s screaming, and tears, and flipped tables, and pets hiding in the basement… And that’s just me. :wink:

1 Like