Problems with Import Mini-Rambo

Hi all,

First all Information of my build:

-MPCNC with Mini RAMBo 1.3A

So i just finished building up my MPCNC and after sorting out all kinds of problems it now moves. When it stops moving, the steppers start vibrating with a loud noise. when i move it arround it does it pretty accurate(it moves 1cm when i tell it to). But just sometimes it seems to be a bit off. I then tried the crown test, but this does not work well at all. it seems like it does way too big steps and diagonals look like stairs. Strangly the diagonal to the starting point seems right, while the rest of diagonals are stairs. I doublechecked all wiring.

My stepping options are following: #define DEFAULT_AXIS_STEPS_PER_UNIT { 80, 80, 3200, 100 }

for a 1.8 degree motor, 20 tooth pulley, belt pitch is 2.5 mm and mini Rambo has 16 microsteps which would bring me:

#define DEFAULT_AXIS_STEPS_PER_UNIT { 64, 64, 3200, 100 } but thats way off from right measurement.

Now i dont know what to do. An idea was that i could have wrong PWM but i dont find where to set it up in the preconfiguered build.

My display isnt working as well while it glows. But i didnt thaught about this problem yet.

First, thanks Bryan, you are such a wonderful person for helping everyone out here :slight_smile: I really love your work.

Thanks in advance!

20190720_233304_x264.mp4 (2.05 MB)

That is a fake minirambo board. You are the first I have heard of one actually moving.

Your LCD needs to be changed in the firmware as it is not the recommended and since you are also not using the recommended 16T pulleys your steps for that axis are 80, but your Z seems crazy.

Did you set the digipots, does it have digipots?

I dont know how to find the digipots or what they are or how to set them up :frowning: you have a link to any information?

At first i set up the motors as the manual for this step told:

[attachment file=106674]

When this didnt worked, the motors didnt moved at all i set them up like this (the right part):

[attachment file=106675]

and it worked just fine like this. could this be a problem others are facing too?

Thats my board:

[attachment file=“20190721_174739 (2).jpg”]

I cant see anything looking like digipot google pictures^^



The board you bought does not seem to work. A lot of people are posting this same thing, you bought an import (not a genuine) and they did something wrong when they made them. I can’t help as I have not seen a fix yet and do not own one. Changing your post title to see if that helps.

If someone got one working please post the fix.