Problems with Rambo 1.4 Dual End Stop Firmware Release 2.0.5.4

Rambo 1.4 board and LCD was purchased from Ryan this spring for use on a Burly build. The Burly worked well but I have recently upgraded to the Primo with dual end stops.
If I try to compile with Arduino IDE version 1.8.13 the compile fails with:

*Arduino: 1.8.13 (Windows Store 1.8.39.0) (Windows 10), Board: "RAMBo"*

*avr-gcc: error: CreateProcess: No such file or directory*
*Multiple libraries were found for "U8glib.h"*
*Used: \\Mac\Home\Documents\Arduino\libraries\U8glib*
* Not used: \\Mac\Home\Documents\ArduinoData\packages\rambo\hardware\avr\1.0.1\libraries\U8glib*
*exit status 1*
*Error compiling for board RAMBo.*

I am using file: Marlin-1CNC_Rambo_Dual which contains version 2.0.5.4. I have tried compiling on both a PC and MACOS. Same Results. It appears to object to having two copies of u8glib. I try deleting the library folder from one or both, deleting it through library manager and adding it back. When I add the library it places it in both directories.

I was able to compile and upload the firmware with with PlatformIO without any issue and the Primo works great with a few exceptions that I am working through but do not affect normal operation. I have solved the problem for my install but wanted to document it for others that use the Arduino IDE exclusively.

I would be happy to try a few things if anyone has an ideas.

I think the first step would be to use the standalone Arduino app, not the Windows store version. Also, were you trying to use a Windows app on Mac files, or is it accessing network files on the Mac? The error you pasted shows Mac in the file path.

On the MAC I am running Windows 10 as a guest OS using parallels so the file structure is NTSC. The same on a PC using Windows 10 as well. I downloaded Arduino IDE from https://www.arduino.cc/en/main/software not the windows store. Is there another version and where would I get access to it?

The MAC file path is how Parallels stores the windows library paths. I can also accessed the files via a traditional drive letter like C: and have tried that as well with the same results.

I have been able to compile Marlin on my Mac using the MacOS version of Arduino, no VM needed. I don’t know if things changed with newer versions of the V1 firmware.

I would also check you are using the correct version number of Arduino as recommended here on the Firmware instructions page.

Edit: https://docs.v1engineering.com/electronics/marlin-firmware/

This page says 1.8.9 is the minimum version needed for Marlin 2.0, and you have .13. There used to be something with a beta version needed instead. I’m still confused why the first line of your error says Windows app store.

I am able to compile earlier versions (Release 2.0) using Arduino IDE but not the latest 2.0.5.4.

There are a number of changes with the current release and generally it is an improvement over 2.0. Here are a few issues though:

  1. Hardware Home (G28) now raises the Z axis 5mm when homing X or Y,

  2. Hardware Hoe (G28) Causes a Rambo reset is homing more than 300mm.

Well, aside from what I’ve already mentioned, there’s nothing else I can think of unless you changed settings in the Firmware. I’m very sure it compiled before it was uploaded to github. Perhaps someone else has some ideas?

I’m glad you found a way to get it working anyway.

I made no changes to the config files or anything else. I will probably be making some to get around the above but plan to keep using PlatformIO since is this a better tool anyway.

You could try using 1.8.12, you can isolate the libraries by creating a portable folder under the main Arduino folder. I would avoid the windows store version as well.

I downloaded 1.8.12 and manually installed in the Documents directory on a real PC. I downloaded the Rambo Board and U8Glib using the manually installed program. Same results.

This is normal. The bed size setting in configuration.h is set to 300mm. You can make it higher, or just move closer to home before sending the G28.

The other issue is something like “safe home z” feature, and it so you have less of a chance of dragging the bit across the work. If you don’t like it, you can disable it in configuration.h.

That double library issue is the red herring, I think. The real issue is that create process error, which I have only seen once before someone posted.

Where did you get that?

Driven from:
https://docs.v1engineering.com/electronics/marlin-firmware/

### GitHub Firmware

If you like to be more up to date with the Newest Marlin features, I have all my most recent updates here.

Github pre-configured.

Ok. I didn’t realize it would name the file that. Thanks for clarifying.

jeffeb3
is this firmware Marlin-1CNC_Rambo_dual is the good one or should i used an other ?

for
rambo 1.4
12 volt ps 6amp
nema 17 stepper 17hs19–2004s1


for a full table 4x8 feet kit whit lowrider 2 CNC
because i tried it and no axis is not working at all !

should i used a 24 volt ps 6 amps insted of the 12 volts ?

please help me !

Thanks

I’m using this version on a MPCNC Primo. Aside from the problems compiling with Arduino IDE states above it seems to work OK for the most part. Homing seems to be a problem on large tables as it causes a Rambo Halt after about 300mm. I think it might be related to bed size and I am working on solving that problem currently. Version 2.0 of the Rambo MPCNC worked well and I could compile it with Arduino IDE.

i am using visual studio code to edit and flash firmware to the unit !
the problem is nothing work so fare if you see in the 1st msg i post my configuration and i dont no if it is the firmware the diférent stepper or the board who is making me the problem it is not clear your response because you dont use the same config as mine !
i am using the lowrider 2 full table unit not a small or mid size i have to chose the right version for my setup from this site


before i do any update on my parts !

there is no mpcnc vervion for the rambo on the site whith dual z stop only ramps it is not the same i think
i am so confused now it is worst

From the lowrider docs:

Firmware

The standard MPCNC firmware will work with any board on the LowRider2. Dual endstop firmware is not really needed since all three axis have hard stops you can use for alignment.

Firmware page.

For the creative of you, you could use the dual end stop firmware for Y alignment or even Z (homing min or max).

That suggests not using dual Endstops. However, if you still want to, the docs say any firmware will work. This means you will likely use V1CNC_Rambo_Dual for your firmware.

Thanks i just check my limit switch and they where NO and i read it should me NC am i right ?
probably thats why nothing was working

The dual works well, but MPCNC is dual x and y. Low rider is dual Y and Z. So you need to edit configuration_adv.h to disable dual X and set the number of Z to 2.

If that seems daunting, just use the non dual endstops and make a little serial adapter at the controller to wire the Z and Y motors in serial. Then after you are cruising and getting bored, you can try to work on the dual and only deal with one problem at a time. I suspect we will be publishing LR versions in the future. But no guarantees.