Question for the Linux Gurus- Maybe coming to the darkside

So iI got this cute little 2-1 laptop from the kids for Christmas. Its a Lenovo Flex 5-14IIL05 Laptop. So since i cant leave thiings alone i upgraded the nvme m2 to a 500GB. and well sinve it now had no OS anymore i had a reason to finally go back and try linux again. I played with Arch 7 years ago but didnt do much.

so i tried Arch again. lol and mint and ubuntu and mx and finally settleed on manjaro. all i tried had no sound and no touch screen. i figured out the sound but touch screen requires a kernel edit which in already done in the 5.11-rc1. so i compiled the kernel with makepkg -s and after an hour fished no errors. Next i run makepkg -i for install and i am getting a cannot move error directory not empty. Any ideas what i can try? Near the bottom is what im talking about

i am following the instructions on this page. and i should be on the kernel install section

Sorry, I have been using Linux as my desktop for 15 years. But I don’t mess with anything that deep. I just use Ubuntu everywhere now, although I like to replace the wm with i3. The hardware is usually very smooth, except for nvidia, which frequently tries hard to break itself on updates.


No worries. Thought i would try my luck here before having to join another forum to ask there.

What’s in the destination directory? If you are trying a mv, it will balk if you try to merge a folder. Make sure the destination is clean then give it another try. If the destination is some place special, like where your live code lives, the use an empty folder for the destination and do a cp afterwards instead of letting the script handle it for you.

well i started reading and found it was supposed to create compressed files to in stall. even though it was failing those files appeared and i decided to see what was in them. one manjaro started installin. ended up it had worked(or so i thought). get confirmation that new kenel was installed. i reboot and the touch screen works but now the keyboard doent work and i counldnt do anything so i took a break.

lol during my break i found another distro that looked good. arcolinux installed 3 differnt desktops and alot of other stuff. i told it to usee the newest kernel because it had figured out how to get the rc version to compile. after the 30gb install EVERYTHING WORKED on reboot.

So i guess now im half way to the darkside. we will see how much i use the desktop on when it will get switched.

Arch is like the dark side of the dark side :slight_smile:

When I first used Linux, this type of fuss was the norm. Almost every computer had some piece of hardware that need specific attention. Ubuntu seemed to really change that, although I didn’t use it for the first several years (I used opensuse, which was also getting much better at that time).

For the last ten years or so, almost every computer I have tried to run ubuntu on works right away. The ones with nvidia graphics still need proprietary drivers, but that’s it. Then I apt get every piece of software I could want and I don’t pay for basically any software (not just the os). And the package manager mostly makes sure the software doesn’t fight each other.

1 Like