Rambo 1.4 and LCD issues

I just finished building my mpcnc and am starting to wire things up. The first thing I did was plug in the LCD screen then I hooked up the power. I get a solid blue screen with nothing on it. If I switch the cables I get a blinking screen and a clicking noise. Any help?

Sounds like a backwards cable. On one side jam them in the wrong way. There has been a streak of wrong cables lately. There are no ways to electrically damage the LCD with the plugs so give it a shot. Also make sure you have the LCD enabled firmware properly flashed.

1 Like

Just tried flipping the cables and I am still getting a blank screen. The LCD is enabled in the firmware. Any other ideas?

One of them must be bad then. Good firmware, you tried all possible plug orientations, that only leaves hardware.

Is there any way to test them? Just pulled everything out of the box today.

Is there any way to test them? Just pulled everything out of the box today.

Other than plugging it in, like test points or something? Give it a real close inspection. One cable is for the SD and one is for the screen.

 

It could be any one of the components. No way to narrow it down without swapping parts. Mega, ramps, adapter, cables, screen, firmware.

I had a majority of my issues with the ramps shield, hence not carrying them anymore. Bad solder under the headers was most common.

So I have tried changing the ribbon cables every way possible and I am still getting nothing on the screen. I am using the duel endstop firmware if that helps troubleshoot. I just received the board and LCD from here about a week ago so I would hope its not a hardware issue. Does anyone have any suggestions?

Lets see the wires. Plug in the wires as intended into the rambo, port 1 is closest to the 4 pin ports. Then on the LCD side force them in the wrong way, port 1 to port 1.

Well…after a fit of rage and trying to get this thing to work for days now, it finally decided it wanted to work. I think my issue was that I was not unplugging the board and plugging it back in so the LCD never reset when I had the correct configuration. Thanks for all your help.

Oh, yeah that would do it.

You should always disconnect all power when plugging and unplugging anything from the control boards. You can do permanent damage.

FYI, I also had this issue and it was resolved by forcing both cables into the slots backwards.

2 Likes

[attachment file=“RAMBo LCD Connection.jpg”]

Same. At least for me, for the RAMBo 1.4 + Full Graphics LCD combo to work, you need to turn one end of each cable 180 degrees. I flipped the LCD-end of the cables. Now they point toward the bottom of the LCD instead of the top. [attachment file=60918]

Amatuer-tip: Clip the notch on one end of your cables so you don’t have to force anything.[attachment file=60920]

The clippers I use for Metal Earth models work well. [attachment file=60921]

2 Likes

Thank you for this. I have a custom rambo 1.4 boards coming the pins are no longer shrouded so this won’t be an issue anymore.

Sweet. I noticed you were sold out. Is anything else different on the new batch?

No that’s it. They are having some supply issues though so it will be a few weeks until I get anymore, so I am only selling the ones I have with the kits. Gunna be a lean month I think, unless I get the PID’s done…

Hello there,
I finished building my mpcnc, but am stuck at the stage of getting the miniRambo to run it.
I have bought two boards now,and two LCDs, all from the V1 shop, and I see from Ryan’s notes that
he has flashed the boards and that they should be plug-and-play with the control. Like other folks, I found I needed to reverse the LCD leads, and with the first board I was able to get the LCD to show
the menu, but could not scroll. Then the board dropped dead. Swapping fuses has had no effect,
hence the second board. With this, I get a blue screen, but no menu. The board responds to
the control selector by blinking the amber communication LED, as it does when the laptop communicates via the USB, (when I try fruitlessly to manually control using Repetier host).
I gather that I should not need to adjust the Baud rate…my system is Windows 10. I have not attempted to re-flash. I am not using end-stops. I have bought a short USB cable with ballasts. I have imported U8glib into the Arduino library. What have I missed?
Peter

Which kit did you buy?

Pete, what happens when you try an connect with repetier? What power supply are you using? I need to see a picture with it all wired up showing all connections in the same shot, both ends of the LCD cables.

Chances are really good both your boards are fine, chnaces are even better at least one is, for windows there has never been a baud rate issue, is your system a windows 10 tablet or computer. More details please.

Hi Barry,

I bought the mpcnc parts bundle with the miniRambo series wire kit and 6 amp Kastar power adapter. The power supply works as it should, I think, with our 240V 60Hz mains supply, here in Aus. The board and LCD light up.