Rambo 1.4 Poor soldering

I’ve been putting together my MPCNC with the Rambo 1.4 that I ordered here. I tested it first with the serial stepper cables, and everything went smoothly.

I then updated the firmware to 513D, and started testing with the individual cables that I ordered from here.

The x1 and y1 steppers seemed to work, but x2 and y2 refused to cooperate.

I thought that maybe I needed to install the end-stop switches, so I did that, and while testing those with the M119 command, I found that the x2_min switch was always showing TRIGGERED, regardless of which switch I connected to the input.

At that point, I happened to flip the board over and was greeted with this:

Needless to say, I was not happy.

I broke out my trusty soldering station and soldered all the suspect pins, checked them with a jeweler’s loupe, and tried again.

Same result.

I’m now thinking that I have a problem board…

The endstop switches don’t play any role in normal movement. They are only used during homing. Are you absolutely certain you installed 513D? X2 and Y2 failing to move is what would happen, if you installed 513S (Serial/Series) firmware by mistake, or if your firmware failed to update. You can swap wires to verify the wiring and the stepper are okay.

As for the endstops, the wires come with the board, and I’ve seen reports on the forum of bad connections in the wires shipped with the Rambo boards. I’ve seen a bad endstop pin on the board only once on the forum. I have read about bad soldering when ordering Rambo boards out of China, but the official Rambo boards are usually well made.

It is possible to reassign an endstop pin if one of your pins is bad. But, because of the way the endstop pins are placed on the board, there have been a number of occasions where someone has used a voltage pin rather than a signal pin. Surprisingly, the pin/board seems to be robust enough to survive this issue. Make sure you use the ‘s’ and ‘-’ pins, and avoid using the ‘+’ pins when hooking up the endstops.

The endstops expect normally closed connections, so if you have some dupont wires, you can short the ‘s’ and ‘-’ pins and run an M119 to make sure the pins are okay.

1 Like

OK, finally have it all sorted out. Turns out the stepper situation was cockpit error on my part., the x2 and y2 were improperly placed.

The endstop problem was caused by two sets of poorly crimped endstop cables supplied with the Rambo v1.4. I used pcboard jumpers, of which I have hundreds, to check the board, thanks for the suggestion

Now I just have to track down the smaller spade-style connectors for the end-stop switches in order to repair the old cables or to make some new cables.

Thanks again for your help.


Or you can just solder the connections. I use the Rambo spade connectors on my switches, and occassionally one gets knocked off. Easy fix, but I’ve considered just soldering the connections.

The endstop problem was caused by two sets of poorly crimped endstop cables supplied with the Rambo v1.4

There have been other posts on this exact problem. UltiMachine has a quality control issue. Glad you got it sorted, and thanks for posting your solutions. Often we give advice on this forum and never hear back about what solved the problem(s).

1 Like